Upgrade confluence - now cannot start - Pre-activation expression": java.lang.NullPointerException

Hello,

 

after upgrade Confluence I have following error message. And I am not able to start it. Will you be so helpful to give me some hints what to do?

It is running on the MSSQL

Thank you.


Lukas

 

In screen "Upgrade Check List [Form]", property "Pre-activation expression":
java.lang.NullPointerException
at com.install4j.runtime.beans.styles.FormStyle.visitControlButtons(FormStyle.java:184)
at com.install4j.runtime.beans.styles.FormStyle.setControlButtonText(FormStyle.java:111)
at com.install4j.runtime.installer.frontend.ScreenEnvelope.setControlButtonText(ScreenEnvelope.java:254)
at com.install4j.runtime.installer.frontend.WizardScreenExecutor.setControlButtonText(WizardScreenExecutor.java:104)
at com.install4j.runtime.installer.frontend.WizardScreenExecutor.setNextButtonText(WizardScreenExecutor.java:170)
at com.install4j.script.I4jScript_Internal_232.eval(I4jScript_Internal_232.java:1)
at com.install4j.script.I4jScript_Internal_232.evaluate(I4jScript_Internal_232.java:*24)
at com.install4j.runtime.installer.helper.Script.evaluate(Script.java:33)
at com.install4j.runtime.installer.ContextImpl.runScript(ContextImpl.java:201)
at com.install4j.runtime.installer.ContextImpl.runScript(ContextImpl.java:195)
at com.install4j.runtime.installer.ContextImpl.runBooleanScript(ContextImpl.java:57)
at com.install4j.runtime.installer.ContextImpl.runBooleanScript(ContextImpl.java:234)
at com.install4j.runtime.installer.frontend.ScreenEnvelope.activate(ScreenEnvelope.java:157)
at com.install4j.runtime.wizard.WizardBase.setScreen(WizardBase.java:121)
at com.install4j.runtime.installer.frontend.WizardScreenExecutor.execute(WizardScreenExecutor.java:293)
at com.install4j.runtime.installer.controller.Controller$1.run(Controller.java:147)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

4 answers

0 votes
Gonchik Tsymzhitov Community Champion Jul 18, 2018

Hello,

 

Lukas, could you clarify more detail info? From which version and to which version did you upgrade? 

 Also, could you provide a more log info? 

 

Cheers,

Gonchik  Tsymzhitov

Hello,

everything started by no space on server -> backups just ate all disk space :(. Confluence was not working. So I deleted backups, restarted server and saw, that it still does not work. So I upgrade the confluence to the 6.10., no success (same error message), then I used 6.9. same error message,...  I think the upgrade was from 6.7.0

Gonchik Tsymzhitov Community Champion Jul 18, 2018

Well, 

what about logs? 

First, Let's upgrade your connector.

 

but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.

 

And then let's flush plugin cache

https://confluence.atlassian.com/confkb/how-to-clear-confluence-plugins-cache-297664846.html

what is ment by that, please? How to upgrade the connector? 

Thanks, I just did it - uploaded jar files to the WEB-INF and restarted confluence, but localhost on 8090 port still does not respond.Capture.PNG

Gonchik Tsymzhitov Community Champion Jul 18, 2018

Please, remove all old mssql connectors. 

You are blocking ClassLoader work. 

I suggest remove mssql-jdbc-6.4.0.jre[7,9].jar files.  and 6.3.0-jre-preview 

 

Cheers,

Tsymzhitov Gonchik

ok, I kept mssql-jdbc-6.4.0.jre8.jar and removed the rest. Restarted confluence, the next check I will do tmrw morning, so I will update this issue.

 

Thank you for now!! 

hello, so same problem. confluence restarted, but it did not start. I am attaching again logs. can you please check? 

https://www.dropbox.com/s/7s4z9q7v9qbhm2i/logs.rar?dl=0

 

I see, there is still problem with the tomcat... :( 

Gonchik Tsymzhitov Community Champion Jul 19, 2018

Well, what is the JRE version are you using? 

it should be 8.

yes, it is 8. just upgraded to the newest version. 

Can I somehow reinstall the confluence? I have the backup, which is made before every upgrade,... 

Hello, any other idea? why confluence won't start, please?

So, now I even reinstalled the confluence, but without success, the localhost does not run...

Gonchik Tsymzhitov Community Champion Jul 20, 2018

May I know your confluence behind the reverse proxy?

It deoes not run on the public IP, as we are behind the proxy server...

Any other idea? :( 

Gonchik Tsymzhitov Community Champion Jul 22, 2018

Let's share configuration of revers proxy. 

like nginx -T result

@Gonchik Tsymzhitov .... I tried to do as much today myself, but from some reason still dos not work.

 

- I found the backup of the HOME folder, and I have a backup of the SQL database

- I uninstalled confluence, removed the Atlassian folder from Program Files

- installed the old version, which was there before - 6.7.0. 

- loaded back the HOME folder, started confluence 

- not possible to open the localhost page, though...

 

 

if I open the atlassian-confluence.log, I can see ...

 

2018-07-24 17:07:21,995 WARN [C3P0PooledConnectionPoolManager[identityToken->1mv4z2c9w1ktz3jr1b5vjvp|3deb97d7]-HelperThread-#0] [mchange.v2.resourcepool.BasicResourcePool] log com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@32872c11 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (30). Last acquisition attempt exception:
com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user 'Confluence'. ClientConnectionId:07ad5860-c806-4c89-a193-398d5124a9cf
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:260)
at com.microsoft.sqlserver.jdbc.TDSTokenHandler.onEOF(tdsparser.java:256)
at com.microsoft.sqlserver.jdbc.TDSParser.parse(tdsparser.java:108)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.sendLogon(SQLServerConnection.java:4507)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.logon(SQLServerConnection.java:3374)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.access$100(SQLServerConnection.java:85)
at com.microsoft.sqlserver.jdbc.SQLServerConnection$LogonCommand.doExecute(SQLServerConnection.java:3338)
at com.microsoft.sqlserver.jdbc.TDSCommand.execute(IOBuffer.java:7342)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(SQLServerConnection.java:2688)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.connectHelper(SQLServerConnection.java:2236)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.login(SQLServerConnection.java:1897)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.connectInternal(SQLServerConnection.java:1738)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.connect(SQLServerConnection.java:1062)
at com.microsoft.sqlserver.jdbc.SQLServerDriver.connect(SQLServerDriver.java:572)
at com.mchange.v2.c3p0.DriverManagerDataSource.getConnection(DriverManagerDataSource.java:175)
at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:220)
at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:206)
at com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool$1PooledConnectionResourcePoolManager.acquireResource(C3P0PooledConnectionPool.java:203)
at com.mchange.v2.resourcepool.BasicResourcePool.doAcquire(BasicResourcePool.java:1138)
at com.mchange.v2.resourcepool.BasicResourcePool.doAcquireAndDecrementPendingAcquiresWithinLockOnSuccess(BasicResourcePool.java:1125)
at com.mchange.v2.resourcepool.BasicResourcePool.access$700(BasicResourcePool.java:44)
at com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask.run(BasicResourcePool.java:1870)
at com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread.run(ThreadPoolAsynchronousRunner.java:696)
2018-07-24 17:07:21,995 WARN [C3P0PooledConnectionPoolManager[identityToken->1mv4z2c9w1ktz3jr1b5vjvp|3deb97d7]-HelperThread-#0] [mchange.v2.resourcepool.BasicResourcePool] log Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@715feaed is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

 

any help please? :(

Gonchik Tsymzhitov Community Champion Jul 25, 2018

Hi! 

 

Could you provide the setenv.sh, conflurencedb.xml ? 

Looks like it is related driver connecting

https://confluence.atlassian.com/confkb/migrate-from-the-jtds-driver-to-the-supported-microsoft-sql-server-driver-in-confluence-6-4-or-later-939505122.html

 

Cheers,

Gonchik

Hi! Sorry to piggy back on your post but I did an upgrade from version 6.6.2 to 6.10.2 and got the same Pre-Activation error.

I have Confluence running as a Windows Service and one thing I noticed was that the executable path did not update to use tomcat9.exe which resulted in Confluence not starting up.  Not sure if that is something you are facing as well.

 

Wondering if Gonchik can advise on that.

 

Thank you!

Hello, I finally fixed it yesterday.  It took me few hours. But it works. uff :)

 

I deleted everything, removed all confluence, etc..

 

I restored SQL DB from backup, installed Confluence 6.7.0., extracted backup of HOME directory to the confluence and setup the parameters to connect the DB.

 

Voila, it started to work - then I did the upgrade to the 6.10.1 and everything is fine :)

Lukas,  if you don't mind me asking, do you have Confluence running as a Windows Service?  If so, when you did the upgrade did you noticed it created a new service with path pointing to the "C:\Program Files\Atlassian\Confluence\bin\tomcat9.exe"?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,303 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you