Untrusted Domain error when connecting Confluence to SQL Server

I'm attempting to connect Confluence to a SQL Server instance I have set up.

Both VM's (Windows Server 2012 R2) are on the same domain and are using the same domain account. 

SQL Server is running as the domain account, as is Confluence. 

My JDBC string is: 

jdbc:jtds:sqlserver://192.168.150.162:1433/ConfluenceTest;domain=domainName

Username: domainName\domainAccount

The firewall for both VMs allow port 1433 both inbound and outbound. 

I'm losing my mind here.

Does anyone have any ideas?

 

Thanks!

1 answer

0 votes
Ann Worley Atlassian Team Dec 13, 2017

Hi Ethan,

It looks like you are configuring an older Confluence version, using the JTDS driver, based on your using "jtds" in the connection string.

If you are using Confluence 6.4 or above, please be aware of Database driver changes  introduced in Confluence 6.4.

If you are using an older version of Confluence please try the resolution described in Cannot connect Confluence to MS SQL Server using a domain account

I look forward to hearing how it goes.

Happy holidays,

Ann

Ah, sorry. Yeah, I'm using 5.8.14 and I'll be upgrading it to the latest version when I get it set up. 

I'll try that and let you know. 

Thanks!

Hi Ann,

 

I've tried what you mentioned and it hasn't worked, as seen in the jdbc string originally. 

When I run SQL Server Management Studio as the domain user and connect to the SQL Server in question it works. It just seems to be Confluence that has trouble connecting with a domain user, even when running EVERYTHING as that domain user. 

Any ideas?

Thanks,

Ethan

Ann Worley Atlassian Team Dec 21, 2017

Hi Ethan,

I understand the Confluence setup wizard is failing for your test environment during the database setup step, even though you used the syntax suggested in: Cannot connect Confluence to MS SQL Server using a domain account and you also setup your database as in this document for Confluence 5.8.x: Database Setup for SQL Server

Do you have the option of changing the Authentication Mode of the SQL server from 'Windows Authentication Mode (Windows Authentication)' to 'Mixed Mode (Windows Authentication and SQL Server Authentication)' and using a SQL server account?

 My next idea at this point is to examine the log to see if you are getting the error message from the knowledge base article (Login failed for user 'MyDomain\MyUser') or if there is a different error message.

I am hoping there will be something descriptive in the log. The log that would have the error is: <Confluence_Home_Dir>/logs/atlassian-confluence.log.

I look forward to hearing what you find.

 Thanks,

Ann

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

321 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you