Unknown User (u.sername) issue

One of our users complained about not being able to login anymore. He had some issues logging in since about a week he told me. Of course, when I stood next to him the logon process worked fine, but he had lost all his tasks and profile picture.

Now, when I search for his username using the search-field at the top of the screen, I see a user called "Unknown User (u.sername)" (offcourse not really u.sername but his true username wink). When I seek his full name I see his full name as a user. When I click either one of them, I get the same profile page of user "u.sername". Confluence tells me that this account was created Mar 30, 2015 12:27, about a week ago.

We didn't made any configuration changes on that date... we did update confluence to the latest version but have done so a week before that date. Nothing was wrong with his account after the upgrade.

In the database I see that this user has two user_key's:

mysql> select * from user_mapping where username='u.sername';
+----------------------------------+-------------+----------------+
| user_key                         | username    | lower_username |
+----------------------------------+-------------+----------------+
| xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx | u.sername   | u.sername      |
| yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy | u.sername   | NULL           |
+----------------------------------+-------------+----------------+
2 rows in set (0.00 sec)

We use atlassian crowd to login to confluence through a local JIRA instance, which on its turn uses Active Directory for authentication. Nothing was changed on both JIRA and our AD at this date as well.

I see that Confluence did a userdir-sync exactly at the time the user was 'created', in the log it says:

2015-03-30 12:27:58,322 INFO [scheduler_Worker-2] [atlassian.crowd.directory.DbCachingRemoteChangeOperations] addUsers adding [ 1 ] users

In the JIRA log however, no changes for the userdir are mentioned.

Could someone point us in a direction on how this could have happened and is it possible to merge both 'user_keys' so this user gets his tasks back?

2 answers

1 accepted

Our problem is solved with the help of Atlassian support. First they pointed me to this bug: https://jira.atlassian.com/browse/CONF-36018

At the end I had to do a lot of extra queries (specific to our setup) to solve this, so I don't think it's a good idea to post those here.

 

OK, in the meantime I learned that someone responsible for our AD did rename the account, but after some issues he reverted this change. I think we can safely assume that this is probably the moment that this issue was originated. I'd still like to know if it is possible to merge both users back into the old one so he gets his stuff (like his tasks and profile picture) back.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,695 views 26 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you