Unable to update Server Base URL in Confluence

I'm trying to update the Server Base URL in Confluence. It was entered as http://localhost:8080/ during install, and I need to change it to an IP address (which will soon be updated to a subdomain). I go to General Configuration > Site Configuration, click on Edit, and in the subsequent form the Server Base URL is grayed out and uneditable. So how/where do I change that? I've tried changing it in the server.xml file, but that just makes it so Confluence won't start.

9 answers

1 accepted

I believe this is a permission issue. Users with 'confluence-administrator' rights can view the page but not edit this specific value. In order to edit this value we will need 'system-administrator' rights.

Thanks Andrew, this ended up being the problem. During setup I made a "System Administrator" who is the only person who could give others (inluding me) sysadmin rights. I had to go into the database and change the settings in cwd_membership to give myself sysad rights. Now things are good.

Thanks for your help!

Hi Stuart,

I did a quick check on this, and I am unable to reproduce the same problem on my end. Since this is the case, can you kindly check if there's any error recorded in the logs file?

Anyway, please note that the changes made in the server.xml file will not be reflected in your Base URL configuration, so I am not entirely sure why Confluence is not starting up anymore after updating the port number in the xml file. Can you kindly confirm if the selected port is not conflicting with any other application?

:8080 does interfere with something, so I have JIRA at :8288 and Confluence at :8090. Each of those apps works fine individually, and JIRA shows the correct URL in the General Configuration admin area. But Confluence, while it works fine, shows the localhost:8080 URL in the admin area and I can't update the URL in the admin. And I get errors when I try to perform certain tasks. The error is something like "You can't do that because the Server Base URL doesn't match the actual URL people use."

You can try updating the baseurl by changing the value in the database directly. This would be easier done using a GUI tool as the value in the db is a long string of xml settings, you need to copy out the whole value, change the baseurl portion, then run update statement. Or you can run a find/replace query.

My suggestion would be to edit the value in your fav db gui.

The table / column / value you're looking for:

bandana table

bandanakey is atlassian.confluence.settings

bandanavalue specific portion: <baseUrl>http://localhost:8090/confluence</baseUrl> (or similar)

update bandana set bandanavalue = (----the entire bandana value not just the baseurl part ---) where bandanakey = 'atlassian.confluence.settings';

I would recommend taking a database backup or a table dump before making any changes to the database.

Can you submit a screenshot?

I've attached a screenshot from the General Configuration edit screen. The "Server Base URL" is uneditable.

I changed my Confluence Base URL to http://confluence.mycompany.com:8090, but now I can't access it. I can however access http://<server_ip_address>:8090. Any clues?

Hi,

After changing in base url, I am not able to access the confluenc wiki with new url. Still old url is working.

Old url : http//<serverName>:8080/pages

Changes url: http//myname.com/pages

After change the url, i have restarted the Confluence service and tried to hit changed url,but not working. When I hit old url then confluence is working. I can not see any where the existing url in any config file/database/baseurl....everwhere changed url is visible, But still why my Confluence is pointing old url???

Please let know the steps to change url for Confluence Wiki and also let me know where I am missing?

Thanks,

Pawan

Hi all

How do i run on port 80?

http://wiki.domain.com

As

same issue how do we fixed?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Friday in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

255 views 11 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you