Unable to preview attachments

Hi,

We are unable to preview documents on our Confluence Server. The server is version 6.4.3 and is currently using the H2 embedded database on Ubuntu 14.04. We have not applied any upgrades to this server, it has always used version 6.4.3. 

When we attempt to preview a document, clicking it doesn't do anything and there is nothing logged in the catalina.out file when attempting to open the documents.

We are able to right click and save documents locally and open them using applications on our computers, it is just the in browser preview that is not working.

Any help would be greatly appreciated! Thanks!

3 answers

1 accepted

6 votes
Accepted answer

We had this same symptom on our dev server running confluence (6.1.2).

 

We found that somehow the Confluence Files modules had become disabled.  Re-enabling them fixed the problem.

 

Confluence administration -> Manage add-ons -> All add-ons -> Confluence Files -> Enable 

We were seeing "download needed" on first click of the "preview" button.  Select "X", or escape , then clicking "preview" a second time would render a preview of the document.

This was acceptable as for a Word doc it allowed us to see the comments which had been entered by others,  (Is there any other way to view these docs, with comments?) then it stopped rendering for all clicks of "preview".  I found this question, followed the suggested answer as "Confluence Files" was disabled, and the behavior is the same as before.  

I don't know if it was enabled previously, or not, as I didn't set this instance up.

Why would the first click on "preview" cause different behavior than subsequent clicks?

h2 is for demo purposes only, you should migrate to a supported database.

 

You should also be looking in atlassian-confluence.log and not the catalina.out file

We understand that we should be using another database, we will be migrating soon. 

I have just checked the log file mentioned above and there is nothing written to the log when I am attempting to preview a file, it just doesn't open.

Do you see any errors in your browser JS or Network console?

There is a "404 Not Found" error when I attempt to launch the preview. It cannot find these paths:

https://domain_name/rest/files/1.0/files/content/1737230/byAttachmentIds

https://domain_name/rest/files/1.0/files/content/1737230/minusAttachmentIds

I can still right click on these files and save and open the files manually. 

I have cleared the thumbnails directory and we get the same error as before (404 Not Found). The preview still doesn't open. 

Did you restart the application after clearing it?

Yes, we did restart the application after clearing the directory. 

Hmm, sorry but I am a bit stuck without digging further into your system. I would consider reaching out to Atlassian support directly.

We are using a starter licence, we don't have any support from Atlassian. It would be great if you could help us further! If you would like any more information I could get it for you. 

I emailed an Atlassian I know, hopefully they may be able to help you out.

0 votes
Ann Worley Atlassian Team Nov 22, 2017

Callen, I am the Atlassian emailed by Boris. :)

I opened a support request on your behalf so we can examine your logs. You will receive an email soon from our portal.

To help Support get started troubleshooting please attach a support zip to the ticket. To create a support zip, please follow these instructions: Creating a Support Zip File via the Confluence Administration Console

I have this same issue on our test instance (server 6.1.2).  Was there any outcome to the support ticket. 

We are still working on finding a solution with Atlassisan support. There has been no resolution yet.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,547 views 25 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you