Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to edit a confluence page

Posted this yesterday but the question seems to have been deleted.

We are trialing Confluence (Cloud) with the intention of using it as a knowledge base for our Jira Service Desk (Cloud).  Our trial is expired so we are currently on the free tier.

I am able create and delete pages but am unable to edit them, not even new pages that I create and before they are published.  All of the editing tools are grayed out except for the color option. I have tried 4 different browsers on as many different machines with the same result so its unlikely a browser/machine setting.

Interestingly a colleague who has exactly the same security group membership as myself across our Atlassian tenant on the other hand IS able to edit the pages I create although he had the same problem last week.  

We are both global admins and members of the confluence users group.

Has anyone come across this before or perhaps can point us in the direction of a solution?

3 answers

0 votes
Deleted user Jan 14, 2020

Even though you have Global Admin permissions, Please make sure , you have EDIT page access in the particular space permissions.

https://confluence.atlassian.com/confcloud/assign-space-permissions-724764762.html

I'm having the same problem.

I click to edit a page, and I get a grayed-out page that is missing the rest of the "wrapper" that that you see in the editor. It looks like it's just the inner <div> of the editor.

Definitely a bug in Confluence.

I can edit other pages in the same space just fine. It's only one set of pages that has this problem.

Note that there are no error indicators when I click the edit icon. If it were a permissions problem, I'd expect to see some kind message that I could not edit this page.

PS: Tried contacting Atlassian via their support page, but that page just comes up with an endless spinner. When you're a communications company, that's the one thing that needs to always work, the "Contact us".

Here's what the full page looks like (ignore blurred private info):

confluence-gray-edit-bug.png

I am in the same boat in our on-prem environment. The whole page is greyed out. Can't click on ellipses. Can't click on edit. The page is not restricted. I have full admin rights to the space. The bread crumbs work and the navigation links on the left work.image.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

429 views 23 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you