Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to edit Pages with Firefox

Hello, i am unable to edit pages with the Firefox Browser (68.0.1). The site opens but all control buttons are grey. I am Site Admin and i have full permisstions on editing.

2 answers

0 votes

Hello Tom,

Thank you for contacting us about this. I'm attempting to test the same but I am not able to replicate this.

Can you send us a screenshot of the behavior? Does this occur in the new editor or the old one (the new editor will have your publish button at the top)?

I would make sure that all add-ons on Firefox are disabled and you've tried it in Private Browsing Mode as well.

Regards,

Shannon

Hello Shannon,

i have tried it with a new installed Firefox Browser. My colleague has the same Problem. As you can see from the Screenshot, i cannot edit any text. I have checkt the Permissions, they are okay. Do you have any other ideas?

Confluence.PNG

Hi Tom,

Thank you for sharing that. I've looked into this a bit more, and I see that its likely your company's network settings that are causing this issue. This was the exact reason for this behavior in the 3-4 cases I saw about this in Cloud Support.

Please share the following page with your network administrator, and ensure that they are not blocking access to any of the following IP ranges or domains:

I hope that helps, but do let me know if you have any questions.

Regards,

Shannon

Hi,

I'm experiencing a similar problem. I have full privileges and used to be able to edit pages but today when I tried creating a new page I also get no editing cursor in the text fields and all buttons greyed out. We do have a proxy and I checked with our IT department but to no avail. The strange thing is that my colleague also uses firefox browser editing confluence pages without problems. Any more ideas? I use Ubuntu 18.04 LTS and Firefox 71.0 (64-bit). Also Chromium Version 79.0.3945.79 shows the same problem.

Thanks for any suggestion.

Regards,

Jakob

Screenshot from 2020-01-02 15-49-58.png

 

Hello Jakob,

Lately this has been affecting users whose network doesn't allow websocket connections. You can test this by going to your browser's Developer Tools console, and see if you're getting any messages about "connection failed". If you do, then you will want to bring this to your network administrators so they can allow WSS connections.

Have a look at this ticket for more details:

  • CONFCLOUD-68168 Edit functions is grayed out in Confluence Cloud for certain users

I hope that helps, but if you continue to have any issues, then I would recommend that you raise a ticket with our support team and they can help you narrow down the issue.

Regards,

Shannon

I was able to fix this issue in several computers by going to Firefox / Preferences, search for "proxy", click on "settings" and choose "Autodetect proxy settings" instead of "Use system settings". My system settings were properly set though. May it be a firefox bug?

Like # people like this

Having the exact problem confirm this does the fix.

Like Shannon Spaniol likes this

It seems that there is a issue when firefox trying connect websocket with HTTP proxy, blocked a websocket request needed for the editing.

 

wss://wikidocs.services.atlassian.com/activationid-services/xxxxxxxxxx/synchrony/v1/bayeux-sync1

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

429 views 23 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you