Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable connect to existing data after upgrade Confluence docker container from 6.15.5 Edited

Dear Sirs,

I use the Confluence server running on Synology in Docker for many months without any problem. For upgrading all docker container (Confluence server included) I use the watchtower. Unfortunately, yesterday the watchtower upgraded confluence to a new version andI can't connect to the confluence anymore.

I dont have a backup file for restoring form a clean install, but I back up every day the home folder. Pointing Confluence container to home, confing and install folder (synology volume) is ignored by Confluence. Restart of the container triggers an installation process that ends with a message "Database Contains Existing Confluence Data (Confluence tables already exist in the selected database)".

My question: Is there a way how to run confluence connected to existing folders and database? My data are stored in MySql server (connect via connection string).


My external folders:

  • ./conf (contain server.xml file)
  • ./home (all home confluence files)
  • ./install (mysql-connector-java-5.1.47.jar connector)


Note: All folders are backed up every day.


My docker compose file:

version: '3.1'

services:

app:
container_name: 'confluence'
image: atlassian/confluence-server:latest
restart: always
ports:
- 8090:8090
- 8091:8091
volumes:
- /volume1/data/confluence/conf/server.xml:/opt/atlassian/confluence/conf/server.xml
- /volume1/data/confluence/home:/var/atlassian/application-data/confluence
- /volume1/data/confluence/install/mysql-connector-java-5.1.47.jar:/opt/atlassian/confluence/confluence/WEB-INF/lib/mysql-connector-java-5.1.47.jar
environment:
- JVM_MINIMUM_MEMORY=1024m
- JVM_MAXIMUM_MEMORY=2048m
networks:
- docker-network

networks:
docker-network:
driver: bridge


Thank you in advance for any help


Pavel

2 answers

1 accepted

0 votes
Answer accepted

After fix Confluece works again! The same problem was solved in other topic.

Hi, I was having a similar if not the same issue as you.

Anyway after the update the config file "confluence.cfg.xml" was overwritten with a new one that triggered the setup mode.

It was my bad that I didn't keep the old image after the update, I should have tagged it before replacing it with the new one.

To resolve I recovered that config file from a previous backup (make sure it is the same version) and switched the image to an unofficial one from cptactionhank/atlassian-confluence (you will need to change the env vars and the volumes mapping)

Hm, I downgraded container to version 6.15.5 and restored confluence.cfg.xml + server.xml files. The Confluence starts without any problem. But both new version 6.15.6 and 6.15.7 always clear the confluence.cfg.xml file and Confluence wants to start a clean installation. It is really bad.

Xbb, thanks for the tip the cptactionhank/atlassian-confluence works well, but I would expect this from the official image. However, I prefer the official one, so I'll wait for a fix or other solution. I am also considering clean installation and recover from last backup.

 

Update

I performed a clean installation of the latest version (6.15.7) and succesfuly restored all data from a backup. Everything worked fine until I restarted the docker container. After restarting the Confluence container, the confluence.cfg.xml file was reset again.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

402 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you