Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trying to do and upgrade and CAS is popping up an error but is allowing the user access.

Trying to do and upgrade and getting the CAS error. Just wanting to see if anyone else has been getting that error.  And if so what have you do to get it fixed.

1 answer

0 votes

We might have, but without the error message, there's no way to know if we have.

Cause

javax.servlet.ServletException: Filter execution threw an exception
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:200)

caused by: java.lang.IllegalAccessError: tried to access method com.atlassian.confluence.event.events.security.SecurityEvent.<init>(Ljava/lang/Object;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;)V from class org.jasig.cas.client.integration.atlassian.Confluence35CasAuthenticator
at org.jasig.cas.client.integration.atlassian.Confluence35CasAuthenticator.getUser(Confluence35CasAuthenticator.java:73)

I have the same error message.

@Billy_Jones  did you manage to resolve the problem?

I also have the same issue error message as above.  My instance of Confluence seems to work fine after just refreshing from the error page.

However, it shows up again when logging in every time.

What version of the jar files are you using? 

@Billy_Jones were you able to resolve the issue?

@Billy_Jones @Rafał Nowakowski 

I am not no longer getting that error now after I updated my jar files and a slight modification to my seraph-config.xml

I mostly followed the guide here: https://www.surekhatech.com/blog/cas-integration-with-confluence 

However I had to update the jars which you can get from maven

  1. https://mvnrepository.com/artifact/org.jasig.cas.client/cas-client-core
  2. https://mvnrepository.com/artifact/org.jasig.cas.client/cas-client-integration-atlassian 

Currently I am using 3.6.2 and 3.5.1 respectively on Confluence 7.4.8

for the seraph-config.xml, I followed the instructions here: https://github.com/apereo/java-cas-client#modify-the-seraph-configxml 

<!-- CAS:START - Java Client Confluence Authenticator -->
<authenticator class="org.jasig.cas.client.integration.atlassian.ConfluenceCasAuthenticator"/>
<!-- CAS:END -->

 Hope this help!

@Peter Yeung and I found that after we enabled CAS using ConfluenceCasAuthenticator instead of Confluence35CasAuthenticator

1) logins with local account (i.e. non CAS) still work and that is good and

2) local (i.e. non-CAS) admin account is not able to access any pages under /admin/* (error below)

java.lang.ClassCastException: com.atlassian.confluence.security.seraph.ConfluenceUserPrincipal cannot be cast to com.atlassian.user.User
 at com.atlassian.confluence.security.ConfluenceGroupCache.getGroups(ConfluenceGroupCache.java:28)
 at com.atlassian.confluence.security.ConfluenceRoleMapper.seraphHasRole(ConfluenceRoleMapper.java:46)
 at com.atlassian.confluence.security.ConfluenceRoleMapper.hasRole(ConfluenceRoleMapper.java:41)
 at com.atlassian.seraph.filter.SecurityFilter.doFilter(SecurityFilter.java:186)
 at com.atlassian.confluence.web.filter.ConfluenceSecurityFilter.applyFilter(ConfluenceSecurityFilter.java:40)

 

Any ideas, suggestions what we can do to re-enable access to /admin/* for local (i.e. non CAS) admin users when using ConfluenceCasAuthenticator? 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Confluence

Miss the Confluence demos at Team 21? Watch them here!

Phew, Atlassian Team 2021 blew by. With dozens of demos and a handful of keynotes, you may have missed some of the awesome Confluence Cloud sessions. Don't' worry, you can watch them all here or on Y...

139 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you