Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,964
Community Members
 
Community Events
168
Community Groups

Trouble connecting slack and confluence

Hi I try and add a slack workspace to my confluence spaces and just get this message: 

{"error":{"message":"Invalid or missing CSRF token","code":"INVALID_CSRF"}}

Any tips on how to sync them?

 

4 answers

1 accepted

5 votes
Answer accepted

This may be because of your browser. I get this a lot on Firefox. Which one are you using? 

I’m using Safari on Mac. Would chrome be better? 

Yes, I highly recommend using Chrome. 

I get many issues when I work on my Safari (main work browser), so having Chrome installed and using it for some add-ons, integrations and connections is the best way to go about it. 

Thanks Kristina I will try it. B:)

Success - Chrome worked perfectly. Thanks Kristina!

I'm getting this with Chrome - and our slack integration has stopped working in the last day or so. Any other suggestions ?

Like Ilia Drozdov likes this

Try removing your cookies for Confluence and Slack and try again. 

I had the same issue in all browsers (Chrome, Edge, Safari etc). It was only solved when I enabled 3rd parties cookies on this authentication site.

3rd parties cookie.png

Like # people like this

@Gui Gouveia this worked for me

It worked for me when change browsers from Brave to Chrome

yes it was the browser in my case too. thanks. I was using Safari.

Natalia I'm New Here Sep 19, 2022

Solved it for me as well! I used chrome and it worked fine, thank you! 🙏🏼

 

on Safari go to preferences > Privacy > disable (Prevent Cross-site Tracking) option. And then try again. This should work. 

Once you have connected slack, you can enable this settings also make sure that you don't have block all cookies enabled because this might mess with the integration as well. 

Hope this is useful 

Like # people like this

I'm a chrome user and have tried a similar option to no avail either :'( 

image.png

try deleting all cookies first then all all cookies then quit your chrome completely and then reopen chrome to see if that works 

Safari settings worked. Thanks!

Still occurs for me as well. 

No success wen opening on different browsers or deleting cookies.

You don't have to delete cookies. You should allow them on your browser. It worked for me.

It's definitely 3rd party cookies being blocked.  Had the same issue in chrome, enabled all cookies, fixed it, set it back to block 3rd party. Privacy is never convenient. But it should be more so. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events