Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,297,446
Community Members
 
Community Events
165
Community Groups

Time to first response fails in embedded JIRA filter

Hello community.

Our company makes use of JSM, JIRA and Confluence (Cloud version)

I'm building some reports for our customers and colleagues.
Now i'm experiencing a curious problem. I made a filter in Jira that shows all the necessery colums I want. Including the SLA columns "Time To First Response" and "Time to Resolution.

However, when I embed this filter in Confluence it says "not Valid SLA" (The SLA is valid as it shows times and markers in the Jira filter and in the JSM tickets.

I've tried this solution:

Time to First Response gadget does not display data 

There are some known causes for this effect:

  1. The chart only registers the first comment added to an issue other than the reporter.  A transition or attachment does not record an entry visible to the gadget.
  2. The custom field '[CHART] Date of First Response' has been associated to a single project instead of globally.
  3. The custom field '[CHART] Date of First Response' has been hidden


This is not the solution. Do you have any ideas on where this could go wrong?

1 answer

0 votes
Brant Schroeder Community Leader Oct 12, 2021

@d_arslan 

The document you referenced is for server.   Can you share a screenshot of what you are seeing?  Also is the filter made up of multiple projects?

@Brant Schroeder 

Can you share a screenshot of what you are seeing?

ofcourse:
image.png

The list: Note the first ticket, that's a ticket in which we failed to respond as a first response within time.

image.png

 

Also is the filter made up of multiple projects?

No this is my filter with an example project and product:


project = "Example JSM Project" AND product = "Project example" AND createdDate >= startOfYear(6M) AND createdDate <= startOfYear(9M) ORDER BY created DESC

I forgot, to make it even more confusing:
The filter shows nicely the SLA's

image.png

Brant Schroeder Community Leader Oct 18, 2021

@d_arslan Can you do a comparison on two or three issues that are showing in the filter but not in Confluence?  Since you blur everything out is it hard to line them up.

Hi @Brant Schroeder

I see i blurred a bit too much. I have a screenshot that shows a couple of ticket numbers.

All issues show in the filter, however the field "Time to first response" of ticket numbers (Key) SUPPORT-453 shows the time (The only ticket where we did not manage to have a response-time within the SLA)

Key's SUPPORT-452, SUPPORT-440 and SUPPORT-403 as you can see have a response-time that shows up in the filter but it gives a "not valid SLA" in confluence.

This is a screenshot where you can see a bit more, i keep the names blurred if that is okay.2021-10-19 08_45_06-2021-10-19 08_39_32-[Kwartaalrapportage Wevi] Issue navigator - JIRA.png

Brant Schroeder Community Leader Oct 19, 2021

@d_arslan Can you share the same issues of the IDs that you shared in the Confluence view that are broken?

@Brant Schroeder  I'm not sure I understand the question, do you wish me to make a filter with the issues above (Support-453, support-452 and support-440) and share this filter with you in Jira?

So you can test this in confluence?

Brant Schroeder Community Leader Oct 20, 2021

@d_arslan Share just a screenshot of those issues in Confluence. 

Brant Schroeder Community Leader Oct 21, 2021

@d_arslan Sorry if I am not being clear.  In your original reply, you shared a screenshot of the issues in the filter results and a screenshot of the issues in Confluence with the issue IDs blurred.  I was wondering if you could do the same again but without the Ids blurred so I could see what it looked like in Jira and Confluence.  I was then going to try and recreate. 

Brant Schroeder Community Leader Oct 21, 2021

@d_arslan I was just looking at what you provided again and I do not need what I asked for above.  I noticed something with what you shared.  Support-453 does not have an SAL on the issue yet it shows in Confluence.  All the other issues you shared do have responses.  I was able to get the not a valid SLA to display when I used an SLA not associated with the issue in that project.  Could you check in confluence if there is multiple time to first response?

@Brant Schroeder  first my reply on your first question: in screenshot 1 i will show the filter results on 2 it is the jira view in confluence: the orange icon is a task, the red icon an incident and a purple icon a change. out focus on sla's and first responsetimes goes out to incidents.

2021-10-19 08_45_06-2021-10-19 08_39_32-[Kwartaalrapportage Wevi] Issue navigator - JIRA.png

image.png

On your second post from yesterday: I was aware on the problem with ticket SUPPORT-453. There is already an issue made on the support site of Jira. Since a couple of days SLA's  disappear on the issue-pages. We've already let the Jira atlassian specialists look into it but they can't see either why this happens.

Brant Schroeder Community Leader Oct 22, 2021

@d_arslan 

Well hopefully Atlassian can figure it out.  Sounds like something is messed up with your index.  Are they still working on it?

@Brant Schroeder 

Yeah they are on it. Thanks for helping out on this issue, I wish you a nice weekend.

Like Brant Schroeder likes this

@Brant SchroederI've an update on the issue in Jira, the Jira part of the problem is solved. The issue on confluence still stays. It seems that that issue was not related to the SLA issue on Jira :(. Have you found something that might be the cause of the confluence reports problem with "time to first response"?

Brant Schroeder Community Leader Nov 01, 2021

What was the issue in Jira?   I have not found a way to recreate what you are seeing.  I wonder if the Jira issue requires your Jira to complete a re-index prior to Confluence working again?

Hi Brant,

 

In issue JST-702777 is the solution (see the reply from Simon to Rudy).

Simon commented:

Hi Rudy, Thanks for contacting us!

My name is Simon, and I'll be assisting you with this case.

I suspect that you are running into a known bug related to SLAs, where the SLA can disappear if the SLA configuration is changed and the stop event of the SLA refers to a past event.

•  JSDCLOUD-3562: SLA disappears if the "Stop" condition refers to a past event

To work around this problem, it's possible to force a recalculation of the SLAs data for only certain issues using the guide on this page: SLAs in Jira Service Management are missing or disappear - Jira - Atlassian Documentation

Furthermore, I'd advise you to add yourself as a watcher to the bug report, and I've also added a private comment linking this case to the bug report for our dev's review.

Please feel free to add any comments you think are necessary and/or important to the bug report.

When this bug is in the queue for a fix, the status will change to In Progress, and you will be notified (as a watcher). For additional information on Atlassian's bug-fix policy, please visit this guide As this is a bug in the product and further updates will be communicated through the bug report, I'm suggesting this ticket as resolved.

That being said, if any additional assistance or if you have questions on how to proceed with the workaround, please let us know! Best Regards, Simon | Atlassian Cloud Support

They were not related. 

A re-index has already been one without success

@d_arslan Did you find a way to get the SLA results in Confluence to work? 

@Magnus Solmyr nope, still no results for this issue, same for time to resolution

 

image.png

@r_kokkeler found this today that worked for me:fyi.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

51 views 0 0
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you