Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The embedded PDF viewer macro (View File) doesn't work in Confluence

Hi All,

The macro shows only the background colour of the PDF, the text doesn't!

What we tried and did not help:

  • add underscore to filename
  • creating view in another space, on another page

The used macro is 'PDF' macro.

Confluence version: 4.2

Maybe the origon of the PDF does matter? I mean when somebody save a jpg to PDF...

Can you please suggest?

Thanks in advance!

Rumi

20 answers

1 accepted

You may wish to try SharpView High-Resolution PDF Viewer for Confluence from AppFusions -- which in my opinion is a much better at rendering PDFs for viewing and reading :)

Hi David,

thanks for the suggestion but I think the official View File macro has to work. Otherwise the SharpView macro is not free so our admins won't support to purchase.

Any idea?

Like NikolayS likes this

3 years later, still having issues -- any update on this?

3 years 1/2 still KO :-(

Like Constance Hua likes this

4 years and still buggy.

Like Constance Hua likes this

Hi all, same problem here with Confluence 4.3.6.

The viewer failed with PDF file version 1.6 and above. With pdf file version 1.5 and below, the viewer is ok.

When i convert files from 1.6 to 1.5, it works ... so PDF file version problem ?

V.

Stephane, may I know which PDF converter that you're using?

I have experienced the same thing even after upgrading our Confluence version from 4.3.6 to 5.4.4.

I'm leaning to it being a Confluence problem, not a PDF one.

I have a page that would not preview a PDF, neither with the PDF macro nor the Attachments macro. I added some very simple PDFs of varying Acrobat-readable versions, and experimented with PDF Optimization. Nothing worked.

I added the same files to my sandbox space and they previewed fine, then when I went back to the problem page, suddenly they previewed fine there. Problem solved? Not likely, but at least it worked.

Hi All,

any idea? It's a very weird problem. We just upgraded our Confluence from version 3.5 to 4.2

It worked well in 3.5 but since 4.2 the problem exists.

Can you please help?

Many thanks!

Rumi

We're having the same problem. Shows up with no view. I've had a few of them work..but not all. Similar to Rumi I tried different things in file naming but can't see a pattern. I think the files are being converted on the backend but I can't seem to find where they are.

at first I thought it was the version of the PDF. But no, it is not bound, the question remains for us. We fixed the problem by uploading new PDF documents, we therefore converted from different applications, such as OpenOffice (export functions), etc ... Nothing special. This requires indeed to have the source ...

This is a tricky problem (PDF formats are not as simple as they look sometimes) which is why SharpView exists - and has existed, supported for 2+ years.

So it really depends on what is your time worth.. our customers have been very happy with the product, and continue to renew.

It also has a ton of advanced browsing features, and iOS non-flash support, if you are browning from Mac/iPhone/iPad.

https://www.appfusions.com/display/SHRPVW/Home

i just came across this very issue and was able to solve it with rasteredge's pdf viewer vb.net . also you can rendering pdf to tiff word and so on.

We just finished demoing SharpView. It's no better than the built in viewer. As a matter of fact, it's worse. At least the built in viewer will have a download link allowing customers to access the document that way. Sharpview will only have the download link once the document has rendered.

We had to remove it from our servers, and just tell people to use the download link if it doesn't render.

We are having this same problem.

Although it only occurs with some PDFs. I have tried it with other PDFs and these have been embedded and work fine within the Confluence page. This suggests to me that it may be a problem with the type of PDF being uploaded but I am not sure why or how this can be resolved.

Hi,

This might be a late response, but you might find it usefull to solve your problem:

The Link Preview (https://marketplace.atlassian.com/plugins/com.xpandit.plugins.linkpreview-confluence) is a great Confluence Utility. You can preview PDF documents, images and webpages.

Try it now.

Best Regards,

PMRodrigues

Same here. Version 5.4.1. Although it seems to appear on older Confluence-versions and not with the current one.

Love to know whats wrong :-)

Same problem with 5.5 with some pdf. Would be nice to have it fixed soon.

Addon Link Preview for Confluence works perfectly!

https://marketplace.atlassian.com/plugins/com.xpandit.plugins.linkpreview-confluence

But I do have to say it works best with the Default Theme and with File List-pages. But a new release is coming soon!

Same issue here, running 

  • 5.10.7

No solution found so far ....

I hope this is not too late, I think I had the solution:

 

1.- Create the page where you want the pdf or powerpoint to show 

2.- SAVE THE PAGE

3.- Insert/attach the file (pdf/powerpoint)

4.- Highlight the file and click the + Insert macro symbol

5.- Click Other Macros and search for the pdf or powerpoint option

This will open the popup of the macro options and it will display the file on the preview section THE ONLY THING YOU CAN DO IS SELECT THE PAGE NAME AND HIT INSERT

It is not going to let you change the size of the file... but at least it will display the document! 

Screen Shot 2019-09-09 at 9.56.08 AM.png

Just to add for anyone still struggling with this in the new Confluence editor, I was unable to get the pdf to preview or insert:

1. Attach your pdf to the page.

2. Enter "/" right below your pdf thumbnail and type pdf.

3. Select the refresh button next to where it says preview

4. Select Insert

5. Publish the page

**Do not enter the current page name if you are on the current page, it will no longer preview or insert even if you do select the correct page name.

Good luck guys.

Thanks that worked!

I hope you check if the page title contains special characters. The PDF file is not visible if it contains a symbol [(:, etc.), but when the symbols were removed from the page title, the file was shown.
I want you to check if it's related.

Its not working for me also. I keep clicking on Insert button but it won't load the PDF at all. Very disappointing :(

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

480 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you