The Excel macro is not honoring row and column limits

Adaptive Staff
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 5, 2018

The Excel macro has settings to limit how many rows and columns are rendered in the finished display.  If a spreadsheet is rendered that has anything in a column or row it is rendered regardless of the limitations.  Example:

A sheet is uploaded that has visible data in 15 columns and 60 rows with formulas to display data in the remaining rows up to row 500.  The macro is configured to display 10 columns and 60 rows.

Once the page is saved all 15 columns and 500 rows are displayed; why?

2 answers

5 votes
HD Nguyen
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 18, 2019

I had the exact same issue as described by Rick. This is how I got it to work.

  1. Update Macro as needed.
  2. Go to the Attachment page of the Confluence page, Delete the Excel file.
  3. Click on the breadcrumb to the Confluence page. The macro should display an error. 
  4. Drag the Excel file onto the page to upload.  The macro should automatically refresh as expected.
vanessa-roberts
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 22, 2019

Thanks, this worked for me. 

Krizsan, Roland
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 2, 2020

Thanks, it works.

I have tried it a different way, I didn't delete the excel file, just opened to edit with excel (companion app needed), and uploaded after a save (without any change). It works too.

M_GruenKerr
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 10, 2020

Worked for me!

Achim Haag April 29, 2022

Works in 7.13.1

John Corwith
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 24, 2023

In 7.19.5 you still can't change the rows/columns without deleting the file, making the change and reattaching the file. But the latter does work in this version. Thank you for the tip. Too bad Atlassian can't be bothered to fix it.

Thomas de Gruchy
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 17, 2023

Thank you for this, finally a solution that works! (7.19.5) 

This was driving me absolutely crazy, wish it was more intuitive.

dror.atariah
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 18, 2024

And the prize for the "Most Intuitive and Straightforward User Experience" goes to setting the number of rows to be displayed. Thanks HD Nguyen. your suggestion still works in June 2024...

2 votes
Rick Mortensen
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 5, 2018

Update to the original question; the problem appears to only be an issue when attempting to change the settings for an already established Excel macro.  For instance:

1. Upload a spreadsheet

2. Insert a macro displaying 50 rows and 12 columns

3. Update macro to display 60 rows and 12 columns

Notice that the number of displayed rows doesn't change.  I tried this with Chrome, Firefox, and IE; no difference.  I also see that it doesn't matter if the macro is deleted, the page saved without the macro, and a new macro inserted with the new settings.  Once a macro is established on a given page it cannot be changed to display a different number of rows or columns (increasing or decreasing the number doesn't matter).

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events