It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The Atlassian Marketplace server is not reachable (Connection refused) behind a proxy Edited

Hi Everyone; 

 

I'm having an issue connecting to Atlassian Marketplace,  my hosted confluence is behind a tiny proxy 10.10.250.10 on port 8888 with no authentication required

The Atlassian Marketplace server is not reachable. To avoid problems when loading this page, you can disable the connection to the Marketplace server. Click here for more information...

 

atlassian-confluence.log showing the following error: 

2019-10-31 10:32:42,604 WARN [http-nio-8090-exec-3] [atlassian.upm.pac.PacClientImpl] fetchMpacAppInfo Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException$ConnectionFailure: org.apache.http.conn.HttpHostConnectException: Connect to marketplace.atlassian.com:443 [marketplace.atlassian.com/34.193.88.221, marketplace.atlassian.com/35.168.52.211, marketplace.atlassian.com/18.208.34.130] failed: Connection refused (Connection refused)

 

I'm able to curl marketplace.atlassian.com:443 & marketplace.atlassian.com on the server   

I also have checked the JVM to include my proxy settings as follows: 

CATALINA_OPTS="-Dhttp.proxyHost=10.10.250.10 -Dhttp.proxyPort=8888 -Dhttps.proxyHost=10.10.250.10 -Dhttps.proxyPort=8888 -Dhttp.pac.proxyHost=10.10.250.10 -Dhttp.pac.proxyPort=8888 -Dhttps.pac.proxyHost=10.10.250.10 -Dhttps.pac.proxyPort=8888"

Not sure what else to check at this point. 

 

1 answer

Hi,

We typically have the following configured and hope it helps,

 

JAVA_OPTS="$JAVA_OPTS -Dhttp.proxyHost=xx.xx.xx.xx"
JAVA_OPTS="$JAVA_OPTS -Dhttp.proxyPort=8080"
JAVA_OPTS="$JAVA_OPTS -Dhttp.nonProxyHosts=*.ourdomain.com\|*.otherdomain.com\|*.corp.ourdomain.com\|localhost"
JAVA_OPTS="$JAVA_OPTS -Dhttps.proxyHost=xx.xx.xx.xx"
JAVA_OPTS="$JAVA_OPTS -Dhttps.proxyPort=8080"
JAVA_OPTS="$JAVA_OPTS -Dhttp.proxyUser=xxxxx -Dhttp.proxyPassword=xxxxxx"

Unfortunately, this is very old syntax. I'm using confluence 7.0 which uses the new syntax of CATALINA_OPTS="-Dhttp.proxyHost={{Proxy IP}} 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

269 views 9 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you