Table of Contents Macro not functional - Confluence 5.9.12 Edited

I read all posts in the Forum that relate to the ToC-Macro and tried all suggestions but it seems like there is another Bug in 5.9.12.

The table shows all headlines correctly but the links don't redirect.

If you refresh the window, you get to the right spot.

 

I would be glad if anyone could help.

Greetings,

Marius

1 answer

Hi Marius,

As part of reading all posts in the forum related to this, did you read https://jira.atlassian.com/browse/CONFSERVER-39960? The description of the issue there sounds similar to yours even though it doesn't specify 5.9.12. Do the suggested workarounds there not work for you?

Thanks,
Marlon

Hi Marlon,

thanks for your answer!

I started playing around with the ToC Zone again and notices something strange that indeed works as a solution.

If the Table of Contents is followed by an empty Table of Contents Zone, it magically works. Even though the Table of Contents Zone is empty, thus not visible in the end and not contributing to the layout.

Anyway, it works. Thanks a lot.

Marius

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,137 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you