Table Border in Confluence

Hi,

I am trying to hide the table borders in Confluence but to no avail.

I have done some research on the web and here but it doesn't look like the question has been answered or it was referring to older versions of Confluence.

I have been trying to make it work with Table Plus as well but does not seem to work with Border = 0

Would be great if someone could help.

Thanks.

11 answers

This widget could not be displayed.

This really should be a checkbox or something. And it should be something you don't have to buy a plugin for. Seriously, this is the most basic html. It can't be a fix requiring a lot of resources. We've been asking for this for a couple of years now. Is Bob Swift blackmailing somebody at Atlassian? Does he have pictures from your last Christmas party? Just let us turn off borders on a table.

Yes, it's a shame.

I've helped myself with Section(column()Column()) elements. So I build up a structure with columns and no borders.

Yeah it looks like there is a kind of plugin mafia. Atlassian doesn't deliver basic plugins such as tabs, border removing on tables, etc... just to get royalties from the plugin vendors... A SHAME...

I'm continuously amazed at the lack of basic support.  It's something people need to know about before getting involved with Atlassian.

I partially do not agree, as Jira support major chuck for a Project Manager. Beautification can always be outsourced. 

This widget could not be displayed.

People have been asking for a check box (to turn on/off borders) for YEARS. I am incredibly amazed that this feature has not been created. This is part of why we are close to dropping Atlassian.

I totally agree with you. I've sent a lot of emails to complain about this "plugin strategy". They prefer to get royalties from the plugin vendors than respecting their customers. Atlassian don't care about their customers, they just want money. Why is it impossible to do tabs for example? We have to pay thousands euro to get that from the servicerocket company. A SHAME. Same for basic functionnalities like borders, etc... Atlassian simply don't care it is like selling a car without electric glass and have to pay a garage to get this extra functionnality. If they continu like this they will loose their customers, as Google will arrive on the market with a better solution...

This widget could not be displayed.

Copy and paste from a Google Sheet to Confluence.  The resulting table will not have borders.

I would like to see the option to turn borders on and off.

Genius! At first I was like it didn't work but then I realized duh I need to make the border white in google sheets. THANK YOU!

I tried, but it dosn´t work sad

doesn't work for me either... This is ridiculous.. 

Ready to leave Confluence for Wordpress.. The amount of basic features missing is horrible.  Only reason I'm even attempting this is because I can't get text to show up beside an image... 

Works with Excel as well (don't create a table, just copy plain cells)

Doesn't work with Excel anymore, btw, folks.

Honestly, there's no better way I've found than to include the tiniest bit of CSS to just kill their selector:

.confluenceTd { border-color: white !important; padding: 0px !important;}

I know we aren't allowed to use CSS because it'll make new users scratch their heads and worry ... however I'm finding that just one line is probably OK here and there, since the damned thing ignores anything you put in the styling boxes. 

Is there a way to insert that css into a Confluence Cloud page? :(

David Simpson Community Champion Sep 06, 2018

No, sorry.

This widget could not be displayed.

Hi All,

I couldn't get any of the suggestions to work for me so I modified @Rachael Birky's suggestion.  Here's what I ended up with.  All the details are included for those who are new to User Macros.  

User Macro

Macro Name: Borderless-Table

Visibility: Visible to all users in Macro Browser

Macro Title: Borderless Tables

Description: Tables contained within this macro will have no borders.

Categories: Formatting

Icon URL:  Optional

Documentation URL: https://answers.atlassian.com/questions/180228

 

Definition of User Macro

Macro Body Processing: Rendered

Template:

## Macro title: Borderless Table
## Macro has a body: Y
## Body processing: Selected body processing option
## Output: Selected output option
## Developed by: Rachael Birky
## Modified by: Ismael Carlo
## Date Last Modified: 1/7/2015
## @param borderless-table:title=Tables without Borders

<style>
#borderlessTableWrapper Th { border: 0; }
#borderlessTableWrapper Td { border: 0; }
</style>

<div id="borderlessTableWrapper">
$body
</div>

I also added the following line in the <style> section: #borderlessTableWrapper Table { width: 100%; }

This works but there is an issue showing an info macro in one of the cells, the title of the info macro is shown but not the body sad I wonder why setting border to 0 for <th> & <td> would affect this macro rendering...

We upgraded to v 5.9.6 and this now works smile

Does it still works with confluence 5.10.8? We've updated it and now, when using the note macro into the borderless table macro nothing is shown.

This widget could not be displayed.
David Simpson Community Champion Jul 04, 2013

@Jennifer Wong: Try adding something like this to Confluence Admin | Look & Feel | Custom HTML | At the end of the HEAD

&lt;style&gt;
	#com-atlassian-confluence th, 
	#com-atlassian-confluence td,
	#com-atlassian-confluence .confluenceTh, 
	#com-atlassian-confluence .confluenceTd {
		border: 0;
	}
&lt;/style&gt;

It should wipe out all table borders in every space.

I'd need boderless table only some times, not for all tables.

Is there a way to get that (without having table plus macro)?

(Confluence 5.1.4)

Thomas

Use the css macro (Content formatting macros) with the above suggestion on the page you need it.

Sorry, for that we had to buy the Content formatting macros - that's unfortunately not so easy ...

Thomas

This widget could not be displayed.

Not sure if this helps, but...

I created a new macro and used this code:

&lt;style&gt;
tableWrapper.confluenceTh {
        border: 0;
    }
tableWrapper.confluenceTd {
        border: 0;
    }
&lt;/style&gt;

&lt;div id="tableWrapper"&gt;
$body
&lt;/div&gt;

Then the style only applies to tables in the macro, so put only the tables that need 0 border width in the macro.

Hi Rachael,

Thanks for provided the code. I created a macro. But when I add a table, I still get borders. Can you please provide the rest of the information you used for the template? I probably made a mistake there.

Thanks,

Rosemary

This widget could not be displayed.

I created a user macro to remove the table border.

Here's the code:

_____________________________________

Category: formatting

Definition of User Macro: Rendered

 

## @param borderless_tables:title=Tables without Borders

<style>
#com-atlassian-confluence th,
#com-atlassian-confluence td,
#com-atlassian-confluence .confluenceTh,
#com-atlassian-confluence .confluenceTd {
border: 0;
}
</style>

<div id="tableWrapper">
$body
</div>

__________________________________________

HTH,

Rosemary

Many thanks guys it is a cool solution, and free...

Added the style suggested by Rosemary without the <style> tag  in a page using the CSS macro, as follows:

#com-atlassian-confluence th, 
#com-atlassian-confluence td,
#com-atlassian-confluence .confluenceTh, 
#com-atlassian-confluence .confluenceTd {
border: 0;
}

It worked for the tables in the page.

Thanks! This worked for me (none of the other Macros above worked).

 

Thanks for the share!

Thanks Rosemary & Mike. This worked. 

This widget could not be displayed.

For table-plus, set class to blank and border to 0.

Hi Bob,

Thanks for the answer.

Not sure if I am doing it wrong...but at the start of the macro it has:

Table Plus | class | border=0

Have I missed something?

Thanks

That should work and does in my test. Open an issue if not.

Hi Bob,

I am using Zen Foundation. Has there been any issue regarding borders reported with confluence users who have this add-on?

Thanks.

Not that I am aware of.

This widget could not be displayed.

@Rachael Birky's code worked for me. Additional thanks to @Ismael Carlo for cleaning it up and making it easier.

This widget could not be displayed.

Thanks to @Rachael Birky and @Ismael Carlo this works very well!

This widget could not be displayed.

Works beautifully. Thank you, @Ismael Carlo !

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

383 views 3 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you