It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Synchrony and soyTemplateRendererHelper errors after restart (Confluence 7.0.1) Edited

We restarted the server hosting Confluence 7.0.1 because we were updating limits.conf to increase the thread limit per this article:

https://confluence.atlassian.com/kb/health-check-thread-limit-858578685.html

After restarting the server, we had issues where users couldn't edit posts, not unlike this error:

https://confluence.atlassian.com/confkb/unable-to-edit-any-pages-in-confluence-6-x-due-to-collaborative-editing-867362716.html?_ga=2.174383457.216037376.1496757070-1991059631.1493377944

We checked Administration > Collaborative Editing and saw the following:

  • Synchrony problems are preventing people from saving their work
  • Editing mode: Collaborative editing ON
  • Synchrony ERROR

We tried using the Restart Synchrony button on this page, but it did not resolve the issue. So we tried following the steps here (deleted the plugin directories and the synchrony.pid file):

https://confluence.atlassian.com/confkb/unable-to-restart-synchrony-after-confluence-was-not-shut-down-gracefully-957128787.html

After we went through the steps above, we restarted Confluence. When it came back up, the top navigation bar displayed this templating error:

$soyTemplateRendererHelper.getRenderedTemplateHtml("com.atlassian.auiplugin:aui-experimental-soy-templates", "aui.page.header.soy", $templateParameters)

Based on what we've read, it seems like this new error is likely a byproduct of troubleshooting the Synchrony error.

For the top navigation bar (and other areas with similar errors), we've tried clearing the plugin cache again, verified that the plugin status in the postgres database (bandana table) is at its default, opened permissions back up on the newly created plugin caches, and restarted a few times:

https://confluence.atlassian.com/confkb/missing-buttons-inside-the-top-bar-with-soytemplaterendererhelper-getrenderedtemplatehtml-error-message-appears-instead-867358888.html

In each case, we are unable to resolve the templating issues, and Synchrony is still an problem.

Looking through the atlassian-synchrony.log file, it does look like we found the following error:

com.hazelcast.core.HazelcastException: Cannot bind to a given address: /... Hazelcast cannot start. Port [...] is already in use and auto-increment is disabled.

And in the atlassian-confluence.log file, we get this:

ERROR [http-nio-8090-exec-6] [confluence.plugins.synchrony.SynchronyContextProvider] getContextMap This instance could not be registered with Synchrony.

We could really use some help resolving both of these issues. We suspect we could limp along temporarily if we could get the navigation bar back and disable Synchrony.

Update: We are still investigating, but we found that the "Confluence Soy Template Renderer for Velocity" module in the "Confluence Soy Template Support" plugin is Disabled, but we're not sure how to re-enable it.

1 answer

0 votes
Thomas Deiler Community Leader Jan 26, 2020

Dear @Greg ,

I had in the past a similar error when upgrading confluence. The reason was that while shutting down confluence the Synchrony process was not terminated. The process occupied the resources. Killing it manually solved the issue. Eventually this helps ...

So long

Thomas

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,368 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you