It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Synchronise problem in Confluence

Kyung A Ko Oct 17, 2011

Hello,

Now in my project, we are using both of JIRA and Confluence.

Recently I have added new users and modified users' information via Crowd.

In JIRA the information was reflected successfully, not in Confluence.

The updated information didn't work out in Confluence.

For example, new user who I have made an account recently tired to log into Confluencem but a message display like "You are not permitted to perform this operation ". However the user can log in JIRA.

Is there anyone who knows what is the problem??

4 answers

0 votes
Pankaj Jangid Oct 17, 2011

User can log in into confluence implies that user accounts are synchronized. And the error "You are not permitted to perform this operation" appears when the user doesn't have permission to use (read/write) any space of confluence. Make sure the user belong to right group or has proper permission in "Confluence Admin > Security > Global Permissions".

Kyung A Ko Oct 17, 2011

Yes, I checked it and the user has a proper permission. That is the problem, which is that the user can login but no permission to access to confluence space. Also I changed a user's name via Crowd. In JIRA, her name was modified but not in confluence. In confluence the name is still not changed. Could you let me know what is the problem?

Pankaj Jangid Oct 17, 2011

Did you try manual synchronization? Here -> "Confluence Admin > Security > User Directories".

0 votes
Kyung A Ko Oct 17, 2011

Yes, I already did it, but still not working out. It was used to working out, but from last week it has not been syschronized. Do you know any idea of the reason? BTW, thank you for your help.

0 votes

Since you already did Global Permissions and User Directories synch - try restarting your servers.

Crowd, Confluence and while you are at it JIRA - forcing a manual synch.

Hopefully that will shake it loose, sorta speak.

==

You have not mentioned what versions you are using - which would also help.

If that does not work, my next question would be do you have these users in groups - and the group has been added to the wiki application config in Crowd?

0 votes
Kyung A Ko Oct 18, 2011

At frist, thank you for your answer.

The version of JIRA is V4.3.

As you suggested it, I have added groups to wiki application config in Crowd.

But, the synchronization is still not working out.

The new users can log in, but not permmited to access to confluence space.

Please advise if there is other suggestions.

Thank you

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Confluence

6 Awesome Ways to Apply Trello, JIRA and Confluence to your Project

I attended  Atlassian Summit 2019  and learned a lot from the presenters, attendees and knowledgeable Atlassian product managers. The presentations I attended focused on applying Agile, pla...

1,473 views 8 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you