Subdomain for Confluence

I want to use the address instead default http://localhost:8090.

I do:

  1. Choose the cog icon , then choose General Configuration under Confluence Administration
  2. Choose General Configuration in the left-hand panel
  3. Choose Edit
  4. Enter the in the Server Base URL text box
  5. Choose Save

And after restart if I go to http://localhost:8090, i get :

Your URL doesn't match

Confluence's base URL is set to but you are accessing Confluence from http://localhost:8090.

Update base URL

If i go to, i get:

Explanation: The Web server refused the connection. 

Try the following:

  • Refresh page: Search for the page again by clicking the Refresh button. The timeout could have occurred due to Internet congestion.
  • Check spelling: Check that the Web page address is spelled correctly. The address may have been mistyped.
  • Access from a link: If there is a link to the page you are looking for, try accessing the page from that link.
  • Contact website: You may want to contact the website administrator to make sure the Web page still exists. You can do this by using the e-mail address or phone number listed on the website home page.

If you are still not able to view the requested page, try contacting your administrator or Helpdesk. 

Technical Information (for support personnel)

  • Error Code 10061: Connection refused
  • Background: The server you are attempting to access has refused the connection with the gateway. This usually results from trying to connect to a service that is inactive on the server.
  • Date: 11/2/2017 10:47:21 AM [GMT]
  • Server:


what is the problem?

  • Source: Remote server

How can i do this?


1 answer

0 votes

Your network is not routing the request to Confluence.

This could be DNS, routing, (I would mention firewalls, but the error is not a block, it's a "not serving", so we know the request is landing somewhere), or that the server you are contacting is not serving pages where you have ended up.

Easiest test is to specify the right port - try - what does that say?

If I try to enter I can log in and receive a notification:

Your URL doesn't match

Confluence's base URL is set to but you are accessing Confluence from

Update base URL

Tell me please what it means?

That's good.  It means your network is routing correctly, and the server is running Confluence as expected.

I assume you really want to change the port number of 8090 so you don't have to have it in the url.  To do that, you need to make the server listen on port 80.  Almost all software (i.e. browsers) assume that if you don't specify a port in a url, then they should use the default one invisibly.  That's port 80 for http.

So, you need to relocate it from 8090 to 80.  You can do that in the Tomcat running Confluence, or you can run Confluence through a proxy.  Most people use proxies because they have other advantages like caching, easier setup and security, and being able to make many services work together to look like one, but you might not need any of that.

Are you going to want to do this with Tomcat, or a proxy?

I think the proxy is more true option.

It's certainly easier on the most part.

Next question is which proxy.  Most people I work with use Apache, and that's the one I'm most familiar with (I worked with a couple of the guys who wrote it!), but you can use any one that has a "proxy" function.  Apache, IIS, nginx, lighttpd and so-on can all do it.  You should choose one that you're most familiar with.

Atlassian has good docs on rigging up Apache, IIS and nginx as a proxy for their services.

Apache need to install and configure on the server on which it is installed Confluence?

Apache can disrupt the work of the already existing proxy-server?

Nope, the proxy can be on any server that can see the Confluence server, and the DNS resolves to that proxy.

It will conflict with existing proxies if it is on the same server as the proxies, unless you configure them to listen on different ports.

That I need to order administrators to ensure that the existing proxy server correctly worked with without port 8090?

I am sorry, I do not understand the question.

Our administrators should enable forwarding on the proxy server with http: // on http: // 8090?

No.  They should proxy <your server name>:8090 to http: //

@Jeroen Overbeeke Thanks, but I don't have the rights to administer a proxy server

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,172 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you