Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Space does not allow anonymous access even though permissions are set to Edited

We have a multiple spaces that are normally viewed anonymously by our customers. However, 2 (and only 2) of these spaces are not viewable by anonymous users even though both the Global Permissions and Space Permissions are set to allow it. If the user clicks a link to get to those spaces, they are presented with a login page. If we set one of those spaces as the home page for the site, anonymous users are directed to the dashboard. We have verified that this is only an issue for anonymous users - licensed users can view the space.

We are using Scroll Versions to create and manage content for multiple versions of our product. We create content from a master space and publish it out to separate public spaces. (Scroll Versions is not active in the public spaces - only in the master.) Both of the spaces we are having issues with were published from a single version in the master space. We published an additional test space from this version and had the same result. Any ideas what could be causing this?

3 answers

1 accepted

0 votes
Answer accepted

K15t was able to reproduce this on their end and is looking into it.

Sorry to anyone else who's experiencing this. We'll be working on fixing this bug,but in the meantime, here are the workaround steps:

  1. Go to the space permissions in the new space.
  2. Remove view permissions for the anonymous users and save.
  3. Edit the space permissions again, give anonymous users view permissions and save.

Note that Scroll Versions is not activated in these public spaces - only in the master space.

Hi @Tracy Szappan

Do the pages in the published space have any sort of restrictions on them? If so, those restrictions will supersede the anonymous permissions.

They do not. We had this space available before, but when we republished, it was no longer viewable. We don't have any restrictions on any of the pages, and I double-checked to make sure that was still true.

Oddly, our administrator restarted the server and it started working. This was the second restart - we'd restarted it shortly after we noticed the issue and it didn't do anything, but the second time fixed it.  It's no longer blocking our customers, but I'd still love to figure out what happened in case it happens again.

I am not 100% if this relates to your case but please be aware I have stumbled about a bug which is related - the Atlassian team is already investigating

https://jira.atlassian.com/browse/CONFSERVER-30161

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Confluence Cloud

Introducing Confluence Cloud for Microsoft Teams (Available for Preview!)

Hi Atlassian Community, Remote work has shifted how teams collaborate, and we’ve heard from many of you that Microsoft Teams has become mission critical to many of your workflows, from how you chat...

2,486 views 21 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you