Setting up a new user

Kimberly McCarty May 21, 2021

Hello,

 

I set up a new user in Confluence and I am unable to set her password without receiving this error.

A system error has occurred — our apologies!

For immediate troubleshooting, consult our knowledge base for a solution.

If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support system with the following information:

  1. a description of your problem and what you were doing at the time it occurred
  2. a copy of the error and system information found below
  3. a copy of the application logs (if possible).

Your Confluence administrator can use the support request form to create a support ticket which will include this information.

We will respond as promptly as possible.
Thank you!

Cause

com.atlassian.user.EntityException: com.atlassian.crowd.exception.OperationNotPermittedException: com.atlassian.crowd.exception.ApplicationPermissionException: Not allowed to update user 'cboylan' in directory 'Delegated LDAP Authentication'.
    at com.atlassian.crowd.embedded.atlassianuser.EmbeddedCrowdUserManager.alterPassword(EmbeddedCrowdUserManager.java:164)

caused by: com.atlassian.crowd.exception.OperationNotPermittedException: com.atlassian.crowd.exception.ApplicationPermissionException: Not allowed to update user 'cboylan' in directory 'Delegated LDAP Authentication'.
    at com.atlassian.crowd.embedded.core.CrowdServiceImpl.updateUserCredential(CrowdServiceImpl.java:312)

caused by: com.atlassian.crowd.exception.ApplicationPermissionException: Not allowed to update user 'cboylan' in directory 'Delegated LDAP Authentication'.
    at com.atlassian.crowd.manager.application.ApplicationServiceGeneric.updateUserCredential(ApplicationServiceGeneric.java:636)

 

 

This is a new user. I have looked through you community and not been able to find resolution.

 

Thank you,

Kimberly McCarty

402-304-3169

1 answer

0 votes
Thiago Masutti
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 21, 2021

Hi @Kimberly McCarty 
Welcome to the Atlassian Community. smile

This error indicates the target user already exists in the connected LDAP directory.

Therefore, the user should authenticate with the password registered in the LDAP, since you cannot change it from Confluence.

I hope that helps.

Kind regards,
Thiago Masutti

Kimberly McCarty May 21, 2021

Thanks! That worked!!

 

Appreciate your knowledge,

 

Kimberly

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events