Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Set ulimit on Confluence setenv.sh

After a failed space XML import, I want to increase the open file descriptors limit of the Confluence user, as suggested on this Atlassian KB:

https://confluence.atlassian.com/confkb/xml-import-failed-with-too-many-open-files-error-200704392.html

and on this:

https://confluence.atlassian.com/confkb/health-check-confluence-open-files-limit-844236751.html

 

However, there are no instructions where exactly to insert the value - "ulimit -n 10000" -  in the file.

Can anyone tell me how it should be done?

Thanks!

1 answer

1 accepted

0 votes
Answer accepted

Anywhere you know the line will be executed. 

setenv.sh is a script that varies by install and settings by site, so they can't just give you a  copy, they are relying on you having a basic understanding of scripts

Most simple place - insert it into the first empty lines at the top of the file.

I've already tried just inserting it in the first empty line, but it didn't work out. That's why I thought it has to be inserted in a specific way.

I tried it again now , and this time, on restarting the service, noticed this message:

"/opt/atlassian/confluence/bin/setenv.sh: line 2: ulimit: open files: cannot modify limit: Operation not permitted"

I searched this message, and it figures I have to set the limit for confluence user also on /etc/security/limits.conf .

I might've tried it before, unless it's said everywhere those settings (on /etc/security/limits.conf) are not for system services. (is that related to the service process gets its limit from its parent process?)

Anyway - thanks - you helped me solve the issue.

It relates to the user the process is running as.

If your application is running as the user "atlassian", then you need to add "atlassian" to /etc/security/limits.conf

Hi @Lars Olav Velle any restarts needed after the changes of /etc/security/limits.conf ?

 

Thanks in advance!

@Lars Olav Velle @Vlad can you provide an example of the format used in `/etc/security/limits.conf`? It appears you need to specifc a username, maybe an @ sign before it, a type soft/hard and an item plus a value. My guess is something like this:

`atlassian    hard    ulimit    10000`

If you wanted the `atlassian` user to set ulimit to `10000`

Limits.conf format:

atlassian hard nofile 10000

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

103 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you