Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

ScriptRunner REST Endpoint section in a hung state

Edited

We are currently trying out ScriptRunner for Confluence to see if we can generate a transmittal in Confluence from information in a Jira issue with custom fields. We are using ScriptRunner on Jira also for this. The idea is the data for the transmittal is in the Jira issue and we use ScriptRunner to automatically generate a transmittal page from the Jira info into Confluence formatted per our template. We did the following:

Created an endpoint for Confluence to receive data from a Jira Issue being created.
Added users to the httpMethod: "POST", groups: ["confluence-administrators"] also.
So it would be: httpMethod: "POST", groups: ["confluence-administrators"], users ["xx", "xx"] to try and fix the edit issue where we couldn't edit the transmittal page that was created from a Jira test issue.

Around this time, both Jira and Confluence stopped working when we think someone started a re-index. (I am assuming they did a full re-index and not a background one...why I don't know) Jira came back up eventually and Confluence came back up a couple hours later. Now when we look at the REST Endpoints section of ScriptRunner, this is all we see:

REST Endpoints.png

We tried clearing out the endpoint that we set up through the console to see if it corrected it but it didn't do anything. We also tried disabling the app and then re-enabling it, but no success. On Adaptavist ScriptRunner's documentation, it says you can run a curl command to delete the endpoint but we don't have access to the Jira server directly so this isn't a possibility for us. We tried uninstalling and reinstalling the app and it didn't wipe the REST endpoints so that didn't work because they are still there.

Does anyone know how to fix this?

Thank you!

1 answer

0 votes
Ram Kumar Aravindakshan _Adaptavist_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jun 19, 2023

Hi @Katie_R

I know this is a pretty old question, but just to clarify, how you raised a ticket on this to the Adaptavist Product Support Page?

If yes, were you able to get a solution for your issue?

Thank you and Kind regards,

Ram

I think we ended up figuring out a way to fix it but I don't remember what the fix was because my coworker fixed it. But thank you for the reply and if we have questions in the future, we'll check it out!

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events