Schema upgrade error from 5.10.8

I'm curently trying to set up a test system for updating our production Confluence. The old one is still at (shame, shame) 5.6.4 and a direct upgrade to 6.3.4 failed, unsurprisingly. So I decided to upgrade to the last 5.x version, 5.10.8, which worked just fine. However, the step to 6 still fails with

Upgrade failed. Please consult the system logs for details. You will need to fix these problems, restore your database and confluence home directory to the pre upgrade state. Then retry the upgrade. Upgrade error message: Cannot update schema

The problem is, there's absolutely no useful info in the logs. No exceptions, no error messages, nothing of the sort I'm used to from Jira upgrades. Here's the entire {{catalina.out}} from the "Starting Confluence' line on:

 

2017-09-12 09:26:06,158 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.3.4 [build 7202 based on commit hash e97769bbf919c0bd667762fc102f557beacb7f94] - synchrony version 1.0.0-release-confluence_6.1-78073294
12-Sep-2017 09:26:06.200 INFO [localhost-startStop-2] org.springframework.context.support.DefaultLifecycleProcessor.start Starting beans in phase 2147483647
12-Sep-2017 09:26:06.223 INFO [localhost-startStop-2] org.springframework.web.servlet.DispatcherServlet.initServletBean FrameworkServlet 'dispatcher': initialization completed in 2088 ms
2017-09-12 09:26:09,688 INFO [localhost-startStop-1] [atlassian.confluence.cluster.DefaultClusterConfigurationHelper] lambda$populateExistingClusterSetupConfig$1 Populating setup configuration if running with Cluster mode...
12-Sep-2017 09:37:29.221 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]
12-Sep-2017 09:37:29.274 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 689129 ms
12-Sep-2017 09:37:32.682 INFO [http-nio-8080-exec-6] com.sun.jersey.server.impl.application.WebApplicationImpl._initiate Initiating Jersey application, version 'Jersey: 1.8-atlassian-16 03/23/2015 10:20 PM'

 

I suppose I can raise the logging level somewhere but am not sure which screws to turn here. All the settings in Confluence itself are on DEBUG already but I guess that doesn't take effect until after the schema has been upgraded.

 

Any pointers would he greatly appreciated.

2 answers

0 votes

Hi there,

The upgrade to 6.0 requires major infrastructure and configuration changes for full functionality. Have you read over this?

https://confluence.atlassian.com/doc/confluence-6-0-upgrade-notes-844235311.html

Hi Ryan,

thanks for your answer! I have, but from the look of it most of it is post-installation and changes that users have to be aware of. I'm not using any proxy or SSL termination for the test system -- have I overlooked anything else I'd have to change in the config that the installer doesn't do already? I noticed it doesn't copy over the MySQL-Connector/J from my old installation so I did that manually; the Galera Cluster 5.6.35 that 5.10.8 worked with should still be fine.

 

cheers,

Matthias

HI Matthias,

Interesting. It might be worth noting that other config files are not always copied over. I would diff the server.xml, setenv.sh, and the web.xml in case any config changes were not carried over. 

Also, since you are not using a reverse proxy or SSL, you will not be able to use collaborative editing. Also note that the syncrony process which was introduced will require additional DB connections. Please also note that the minimum requirements went from 2 cores to 4 cores for Confluence and that the introduction of the syncrony process also means that at least 1gb of additional RAM is needed.

That said, it is unlikely that the hardware requirements are what is causing the failure. It is much more likely that there is a configuration error somewhere in the files I mentioned above. However, that still doesn't feel like the most likely issue...

So I found this link that may be more relevant to the situation:

https://jira.atlassian.com/browse/CONFSERVER-52103

Cheers,
Ryan

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,109 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you