Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SSL https not working Edited

Hey guys, 

I've setup SSL using this guide https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html however whenever I try to hit my site using port 8443 I get the 'this site can't be reached' as if the page doesn't exist. 

I have the ports open on the router and to the best of my knowledge I've set this up correctly. The only thing I think I may have gotten wrong was the CN when generating the cert, I used name on the OS 'confluence' instead of the FQDN but I don't know how to generate a new cert to fix that. I'm running confluence on an ubuntu vm. 

Any suggestions would be super helpful, thanks!

 

2 answers

0 votes

Normally, you'd access SSL enabled sites on port 443 (browsers assume 443 when you use https too, so you can usually drop the port completely when using https).

8443 is usually the internal control port, so I'm curious as to why you've changed that and then tried to enable https on 8443 when you don't really need to?

Hey Nic, 

Thanks for your reply. So I use DDNS currently (upgrading to static IP soon) so I currently use port 8090 to access confluence remotely over HTTP (insecure, I'm aware). So currently http://DDNS:8090 will take me to confluence so I assumed https://DDNS:8443 would take me to confluence over SSL but this doesn't seem to be the case. Even locally when I try https://LOCALHOST:8443 it won't work. Am I doing something wrong?

Many thanks, 

Ryan

Yeah, I too have this same issue, I am not able to use the https://localhost:8443 after base URL change. I am struggling for 2 days on this issue. can you pls help me with what am I missing. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

177 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you