Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Roadmap Planner, script-errors

I'm working with a the Roadmap Planner on several pages and recently it's impossible to update or edit any of my existing plans. I've also tried to add new plans but I see the same error.

I can add some bars but once I start editing the texts in the bars I get an javascript error on the page when clicking the "Insert" button from the Planner.

Anyone else experiencing this and have some tips for a work around?

The errors says: undefined is not an object (evaluating 't.pageLink.wikiLink.replace')

Skärmavbild 2023-10-23 kl. 14.21.14.png

3 answers

1 accepted

0 votes
Answer accepted

Atlassian have a bug open for this on their side. Just need to sit tight and wait. :)

Confirming that this issue as started happening recently on our instance. One of our users who often uses the confluence roadmap macro is getting the same issue, which I verified and able to reproduce.

0 votes
John Teeter
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Oct 23, 2023

The same issue is hitting me. The console has:


2com.atlassian.confluence.plugins.confluence-roadmap-plugin:roadmap-editor-resources-conf-frontend.js?assetVersion=1000.0.0-496393053b5b&externals=__local-default__&locale=en-US:23 Uncaught TypeError: Cannot read properties of undefined (reading 'replace')
at com.atlassian.confluence.plugins.confluence-roadmap-plugin:roadmap-editor-resources-conf-frontend.js?assetVersion=1000.0.0-496393053b5b&externals=__local-default__&locale=en-US:23:764
at Array.forEach (<anonymous>)
at com.atlassian.confluence.plugins.confluence-roadmap-plugin:roadmap-editor-resources-conf-frontend.js?assetVersion=1000.0.0-496393053b5b&externals=__local-default__&locale=en-US:23:691
at Array.forEach (<anonymous>)
at n (com.atlassian.confluence.plugins.confluence-roadmap-plugin:roadmap-editor-resources-conf-frontend.js?assetVersion=1000.0.0-496393053b5b&externals=__local-default__&locale=en-US:23:664)
at HTMLButtonElement.<anonymous> (com.atlassian.confluence.plugins.confluence-roadmap-plugin:roadmap-editor-resources-conf-frontend.js?assetVersion=1000.0.0-496393053b5b&externals=__local-default__&locale=en-US:23:2170)
at HTMLButtonElement.dispatch (3.6.1-conf-custom-m03.js:2:49404)
at y.handle (3.6.1-conf-custom-m03.js:2:47395)


And it's happening (at least) whenever the string inside a bar is changed.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events