Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Roadmap Planner inserts a new planner after edit?


I'm running a trial in Confluence Cloud and can't get Roadmap Planner to work correctly.

When trying to edit an existing Roadmap on a page, Insert button inserts a new Roadmap Planner to Page Properties section instead of updating the roadmap which was being edited.

Steps to reproduce:

  1. Add new page using Product Requirements-template.
  2. Add some content, including Roadmap Planner and publish the page.
  3. Go to Edit mode and edit the content of Roadmap Planner. RP editor shows Insert and Cancel buttons at bottom right corner of edit dialog.
  4. Hit Insert. A new RP appears in Page Properties while the RP which you started to edit stays intact.



After testing this a bit more, problem seems to occur only when Page Properties macro is present and Bar is renamed.
Everything works fine when page does not have Page Properties macro. When Page Properties is present, moving bars works fine but renaming a bar will result a new planner being inserted into Page Properties section.

3 answers

2023 and still not solved.

To vote for the issue (there seem to be two):


**EDIT** the last issue mentions a workaround


  • Create a new line above the Excerpt by hitting Enter/Return;
  • Create a new line above the excerpt and add some text to it.


This is not an answer but I can confirm that roadmap planners always do an insert even when going into edit mode (clicking the pencil) in Confluence Cloud.

I've tried this for both:

  • Using the roadmap planner object that gets generated with the Product Requirements template
  • Creating a new /roadmap planner 

It will always produce an Insert button and adds the updated roadmap planner to the top of the document and keeps the previous version where it was sitting in the Milestones section of the document.

If you're regularly updating roadmaps, this is really painful.

I've discovered that bug only happens after a certain amount of time. To be clear: the button and roadmap title text always say "Insert". 

  • If I make a quick update to the roadmap and click "Insert", it updates the roadmap
  • If I take a while to make changes and click "Insert", it creates a new roadmap at the top of the document within the page properties.

I haven't done an experiment to see that that time threshold is.

Hi there, I have used the /planner function in Confluence today and can confirm that indeed a new planner is inserted every time it is edited instead of updating the original planner object.

0 votes
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Oct 28, 2021

@Jouni Karppinen can you try going into edit mode and then /jira roadmap?


When I do this, it shows the roadmap from JIRA and updates every time.

@Marjorie this is for roadmap planner objects, not the JIRA roadmaps

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events