Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Remove/fix automatic horizontal scrollbar on tables

rasmus.brattstrom November 20, 2019

Hi, I have a problem with most of the tables in the new centred page layout. Anytime the page is viewed on any resolution lower than 1920x1080 resolution some tables suddenly have a horizontal scrollbar, even when the table is not wide enough that it should need it. Is there any way to disable the scrollbar or fix this issue?

Thanks in advance. 

15 answers

14 votes
Gilles Lesire November 5, 2020

This bug is so damn annoying.
As soon as you add a table to a page that already had tables. They all get unncessary ugly scrollbars when published. (Not shown during editing).
Please fix this. 


Naamloos.png

Jenni Claire Postlethwaite December 16, 2021

Starting to think excel is easier 

Like # people like this
7 votes
George Linsdell May 11, 2022

Another workaround if you have already inputted content into the table, and the auto scaling does not let you resize the Rightmost column:

  1. Add column right
  2. Resize the column which could not be resize previously.
  3. Delete newly added column. 
  4. The horizontal Scroller is gone

 

Dear Atlassian, Here are the steps to repro.

  1. Create Page keeping default narrow width for overall page.
  2. Insert Table ("Default 3x3 is fine")
  3. Insert a new line and some text after the table so it is not the last thing in the document.
  4. Insert Text Content into all cells.
  5. Set content width for table item to full screen width
  6. Resize the Table columns to bunch column 1 and column 2 to be smaller than column 3
  7. Publish
  8. Now good luck trying to get the scroll bar to dis-sappear. without adding a deleting the last column as suggested above.

 

I'm finding that Anthony's workaround doesn't work if you have already populated the table with content. And that trying to manually drag the Rightmost Column doesn't work, and therefore the horizonal scroller remains. This is the case even if there is sufficient whitespace in the Rightmost column to permit shrinkage of the column with.

Anthony's workaround when creating a new table.

"Edit the page again, then hover the mouse over the right hand most table edge, and click drag to resize the right hand edge. It doesn't move, but it might rescale the other columns. Drag to the left enough, then publish the page again." 

3 votes
Lukas March 5, 2020

Same issue for me. If I edit the page on larger screen and save it, then on smaller screens the scrollbar is always present.  This happens for normal tables and also for tables inside the properties macro. It is really frustrating as page is full of scrollbars. I'm using the new editor and 2 column layout.

image 1.png

Corin Fairchild March 12, 2020

I'm having exactly the same problem in Confluence Cloud.
This looks like another dead end feed with no answer. There are many of these asking the same question.

Like Liz D likes this
Jamie Counsell July 10, 2020

Exact same issue here. Very frustrating. @Diego did you ever follow up with the original asker on this?

Chetan July 30, 2020

Here I am ... facing the same issue. I keep getting horizontal scroll bar even though the table only has 1 or 2 columns.

Samuel Mäder October 22, 2020

Same here, horizontal scrollbar in a two columns layout for most tables (sometimes I can remove them by changing the table width, but it works just sometimes).

Like # people like this
2 votes
Ida Rogalska January 23, 2023

Any chance this problem will be fixed?

2 votes
Anthony Rice December 16, 2021

The quickest fix I have found, when adding a new table to a page, then publish the page and the horizontal scrollbar appears ...

 

Edit the page again, then hover the mouse over the right hand most table edge, and click drag to resize the right hand edge. It doesn't move, but it might rescale the other columns. Drag to the left enough, then publish the page again.

 

The horizontal scrollbar is then gone - you can edit the page and adjust the other column sizes again. 

 

This has been the most reliable solution I have found. 

Jenni Claire Postlethwaite December 16, 2021

Thank you! 

Like # people like this
2 votes
Diego
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
November 27, 2019

Hello there, @rasmus.brattstrom !

As I understand, your table is displayed with scrollbars even when you do not need them. Having incoherent behavior or visual can be frustrating.

I tried to replicate this in a 1280x720 screen but the behavior you described, is not present. Here is what I see:

TableScrollbar.jpg

 

Would it be possible for you to send us some screenshots of what you actually see when tables are viewed? Just be sure to not disclose any kind of sensitive information within those screenshots. Community is an open space and anyone can see what is posted here!

Also, could you describe how was the process of creating the page and tables that show the problem? This can help us to try and replicate the issue locally.

Looking forward to your reply, Rasmus.

Nicolás February 25, 2020

Hi, I'm having the same problem. When I publish the page, horizontal scroll bars appear on all tables, but while editing I dont see them:

Edit view.jpgpublished view.jpg

Any ideas on how can I solve this issue?

Like # people like this
Nicolás February 25, 2020

I just want to add that if the side bar is collapsed the horizontal scroll bars disappear.

Nicolás February 25, 2020

Hi, I have the same problem:

Like Robert Gates likes this
Anthony Rice February 26, 2020

Same problem here.
I have a page with three tables, with two columns each. In viewing mode two of the tables show horizontal scrollbars, but in edit mode the columns are all sized the same on each table. Only the text length varies in each.

rasmus.brattstrom February 28, 2020

Hi Diego, Apologies for the late reply, I've attached some screenshots showing the issue. It seems it's a problem with tables placed in columns, The scrollbar is only shown on lower resolutions. On my 1920x1080 screen there's no issue, regardless if I have the side menu shown or not, but on smaller resolutions, it seems that the tables have the horizontal scroll bar any time the sidebar is on as well, even if there's still plenty of space on the sides and no need for the column to be resized. Same happens if I unmaximize the browser window to a smaller size on the 1920x1080 screen. There's no zoom applied in either chrome or via windows. 

xUHwMjXwtH.png3LLy1QdQtZ.png

Thanks for looking into this.

Andrew Darrant September 28, 2021

Diego - have you had any joy on this in the last 2 years - I just want to stick a table in a column but it seems to automatically make the table a huge width with no way of changing it hence you get a big horizontal scroll - basically making it impossible to create nice pages!

1 vote
Stephen McCafferty
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 8, 2024

More than 4 years on, and apparently nothing has happened in this regard. Our company recently moved to cloud, and as a result, loads of pages now have a horizontal scroll bar in tables where previously there were none. I'm having this issue with tables that consist of a single cell (used in conjunction with page properties) - there really is no reason that I should have to go in and manually edit all the pages that have this issue in a tables with a single cell. There is also absolutely no reason why fixing it should be so convoluted and be a multi-step purpose involving adding an unneeded cell just so I can resize the existing cell before deleting the unneeded cell.

How about adding the ability to automatically adjust the width of tables to the size of the monitor, at least in those situations where that makes sense? I can understand that a table with 20 columns won't fit on a single screen. But it makes no sense that tables that previously worked fine under any resolution are now illegible and require manual editing. It also doesn't make sense to have cells that are wider than can be displayed on the screen without a scroll bar. It makes reading the contents of the table an absolute chore, requiring you to constantly scroll left and right on every single line of text. Given that my texts are 20+ lines of text, that's an awful lot of scrolling for every single user visiting the page.

Please fix.

1 vote
Bas Zwaan February 24, 2022

Problem is still there. Any fix? We are about to upgrade Confluence but I am starting to get regrets.

Gilles Lesire February 24, 2022

This has still not been resolved, the only "solution" is to minimize the sidebar on the left. Which simply impacts the user experience.
Frankly disappointed Atlassian has STILL not picked up on this. A simple feature that used to work perfectly fine and is so important to readibility of pages. 

I mean it is just a table, with no specific width settings. 

Like # people like this
Andrew Darrant February 24, 2022

I gave up on Confluence entirely pretty quickly basically this issue and it being impossible to change font size makes it far too frustrating to use. 

Like # people like this
1 vote
jonlar May 5, 2021

You can manually adjust the size of the columns in edit mode to fix this.

Gilles Lesire May 5, 2021

Yes, let me just go over thousands of pages and edit them manually for a bug that caused this automatically. Only to have it reappear randomly just a bit later.

Like Christie Gera {Appfire} likes this
jonlar May 5, 2021

I've only seen this once, and it was an edit by another person, so I have no idea what he did to make it happen.

Just posting a quick fix that worked for me for anyone else to use, or not.

Like RPT Admin likes this
Jen Schaeffer August 27, 2021

@RPT Admin I see you liked this, but how do you do it? I've been fighting with this for months. When a table is in a column, it maximizes to fill the entire horizontal space. I can't make the entire table skinnier, just make the individual columns larger or smaller.

RPT Admin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 31, 2021

Sorry I have no solution. To be fair, I haven't noticed this problem in any of my sites for a long time - but I think that's because they're mostly mature sites that are rarely subject to major updates. When I see this issue again, I'll be straight back to this page to check for progress. 

0 votes
Armands Šlihte December 16, 2021

Atlassian why is this still not fixed?

 

Diego tested this in 1280x720 screen, why does that matter? There should never be horizontal scroll bars on tables what ever size. Scroll bar on whole page is fine, but not on each table!

 

2,5 years and this is still not fixed?!

0 votes
Jenni Claire Postlethwaite December 7, 2021

has this been fixed as I have this same issue?

0 votes
James Petrovic October 18, 2021

Whilst not a true solution (rather just a quick visual hack), if I Zoom OUT of the page (i.e. Cntrl+Scroll on mouse wheel) so that the page is zoomed at say 80%, then the scrollbar disappears from the table.  Conversely, if I zoom IN to say 110% then the scrollbar reappears...

Page Zoom 80%
PageZoom80Perent.png

 

Page Zoom 110%

PageZoom110Perent.png


Hope that helps.

0 votes
Andrew Darrant September 28, 2021

Is this going to be looked at - it seems there is no way of putting a table in a column and having it correctly size - the more I try the worse it gets - its horrible!

0 votes
Ron De Jesus April 9, 2021

Have the same issue - it's ugly AF.

0 votes
Norma Magalhães November 26, 2020

Hello,

 

I have the same problem. Do you know already how to fix it?

 

Thank you.

Liz D December 4, 2020

No one knows how to fix it.. Atlassian apparently does not notice or does not care that this issue exists. It's been a problem for over a year (at least), and it has actually gotten much worse recently. 

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events