Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,025
Community Members
 
Community Events
176
Community Groups

Recovery password does not work

I have lost the admin password for my Confluence site (server v7.3.1) and am following the instructions here:  Restore Passwords To Recover Admin User Rights | Confluence Data Center and Server 7.3 | Atlassian Documentation

After completing the changes and restarting the service, I enter Username=recovery_admin and Password=<the password I created>, however the screen simply refreshes and the URL changes to this:  http://localhost:8090/login.action?os_destination=%2Findex.action&permissionViolation=true

I tried it with a couple of different simple passwords to ensure there wasn't something wrong with the password, but still no luck.  No message, no nothing to indicate what the problem is.

Strangely, when I enter Username=recovery-admin (i.e. with a hyphen), I at least get a message indicating that the username and/or password are incorrect.

Any ideas?  I'm stumped.

2 answers

@Fabio Racobaldo _Herzum_ 

Thanks for your response.  I stopped the service, then updated the Java Options placing this text... "-Datlassian.recovery.password=ABCD1234" at the end (see screenshot).  I clicked Apply, and then OK, and then restarted the service.

Next, I launched the application on localhost and entered the new credentials.  It spins for a few seconds, and then the screen simply refreshes, no error message.  When I try a second time, same thing.

When I try a random account, an error message is provided, "Sorry, your username and/or password are incorrect. Please try again."

image.png

Any help or suggestions are welcomed.  I am considering trying the database method next.

Thank you.

probably, that option is not stored at registry level and it caused your issue.

Ciao,

Fabio

Hi @Fabio Racobaldo _Herzum_ 

Thanks, I checked under HKEY_LOCAL_MACHINE >> SOFTWARE >> Wow6432Node >> Apache Software Foundation >> Procrun 2.0 >> CONFLUENCE(etc)...

and the entry for the password is listed there, so I do not think that is the issue.

0 votes

Hi @Catherine Tarrant ,

please verify that you placed 

-Datlassian.recovery.password=<your-password>

in the right file and that you restarted your instance. 

Could you share portion of your file settings so that we can check?

Fabio

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.3.1
TAGS

Atlassian Community Events