Problems with Confluence on Server 2012 R2

We tried installing Confluence on a Windows Server 2012 R2. The setup process completed without any errors. However, the "Atlassian Confluence" services does not start. In the error log, it shows event id 7024 - "incorrect function". How can we fix that?

2 answers

This widget could not be displayed.

Hi Timo,


Do you mind to provide us the stacktrace from <confluence-home>/logs/atlassian-confluence.log and <confluence-install>/logs/catalina.out?

That will give us more information regarding this error.

This widget could not be displayed.

We solved the problem ourselves. Your current installer (5.5) does not properly install Java JDK so that it had to be installed manually. Thanks a lot for your support.

Thanks for your feedback. We will look into this matter.


Just a reminder, Confluence 5.5 has not been officially release yet. I believe you have installed the Early Access Program version of the Confluence https://www.atlassian.com/software/confluence/download-eapwhich is not recomended for production usage.

I would advise you to use the stable version of Confluence like 5.4.3 which has been officially tested and released if you plan to use it for production.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

468 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you