Problems while migrating Confluence to a new server

Hi, guys.
I am here to get your help. 

 

I've tried about for all day for what I want to do, but I am now in stuck. sad

If you guys give me some solutions to so solve the problem, then I really appreciate for that. smile

 

I have wanted to transfer to a new server from the original server so I followed the steps below link.
https://confluence.atlassian.com/display/DOC/Migrating+Confluence+Between+Servers 

It is from CentOS to CentOS, so I can say both are the same OS although their version is different.

And the version of Confluence is 5.4.1.

The original confluence has used a default database, so at first I wanted to transfer it without an external database.

So I didn't do any of stpes in upper link.

 

I made zips of home which belongs in '/var/' directory and install which belong in '/opt/' directory.
And then by using 'scp' command, I copied them to the new server which doesn't have an installation of Tomcat which means it is really a new server. 

I unzipped them to proper directories that are '/var/' and 'opt'.

Till this, cuz the confluence doesn't use an external database, so I thought  I could start the confluence on the new server 

But there was one thing I missed.

After searching, I tried something through the below link.

https://confluence.atlassian.com/display/DOC/Creating+a+Dedicated+User+Account+on+the+Operating+System+to+Run+Confluence

sudo /usr/sbin/useradd --create-home --comment "Account for running Confluence" --shell /bin/bash confluence


I thought after I should shutdown on the original server, I had to execute start-confluence.sh. 
So I did.


There are two errors where are located in the different server.

  1. on new server, although I entered that command, there was below error.
    ERROR LogMananger.repositorySelector was null likely due to error in class reloading, using NOPLoggerRepository.
     
  2. After upper error, cuz I could not start the confluence on the new server, I entered 'sudo /usr/sbin/useradd --create-home --comment "Account for running Confluence" --shell /bin/bash confluence' on the original server.
    But I can't start the confluence.
    It worked well so far, but not now.
    The error msg is.. 'com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.NullPointerException'


Although my English skill is not good, so I am worried about that I didn't give you guys enough information to understand this problems, but it will be really helpful for me if you guys give me an idea.

Thanks.


 

 

 

 

 

1 answer

I recovered the way to run confluence on the original server.
 

chown - R confluence:confluence /opt/atlassian/*
chown - R confluence:confluence /var/atlassian/*

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

631 views 21 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you