Problems when updating content - Error 500

Aitor Gastaminza Unanue
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 11, 2023

Hi,

 

I'm getting the following error when I try to PUT a table through the API:

"com.atlassian.confluence.api.service.exceptions.InternalServerException: com.atlassian.confluence.content.render.xhtml.migration.
exceptions.UnknownMacroMigrationException: The macro '"start_date"' is unknown."

The payload I am using is the following:

var payload = {};
payload.body = {"storage": {"value": "<ac:link><ri:page ri:content-title=\"NEW TEST\" ri:space-key=\"SO\" /></ac:link>" (I figured out this from a different post but not sure if it is necessary) + html, "representation": "wiki"}}; //
payload.type = "page";
payload.id = "3543662593";
payload.status = "current";
payload.version = {"number":version_num+1};

 

Where the html is:

1. I get the current page which contains a table.

2. Locate a table and I add some rows to the table

The rows are a <tr> tag which contains the subsequent tds. In each of them I have different stuff. To fill this rows I parse a CSV with the data for each row. On one of the tds I have a JSON style typed text, in the end parsing a line like: 

FR,SO22,"{""start_date"":""N+0"",""end_date"":""N+0"",""new_date"":""N+1"", ""reason_id"":4,""country"":""FR"", ""filename"":""draft""}"

Seems the error is coming from the quotes, but I have also tried deleting all of them, getting rid of the {} but without any luck. Has anybody struggled with anything similar?

 

Many thanks!!

 

EDIT: I have also tried just downloading the data and updating it again without any changes, with the following 500 error:

java.lang.NullPointerException: null

0 answers

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events