Problem with IIS and Confluence

I'm new to Confluence, I have just installed a new production edition of Confluence that works with Active Directory integration. Now I want to get a seemless login experience using IIS and Windows Authentication. I followed this tutorial:

http://confluence.atlassian.com/display/SPCON011/Access+Confluence+using+Integrated+Windows+Authentication+via+IIS

Except for a few errors in the tutorial it was straightforward. But now when pointing IE to http://localhost/ on the local server I get a Tomcat 404 error.

Can someone give me some pointers as to where I should look for errors. I have looked in the logfiles and event log for errors but haven't found anything that makes sense.

OS: Windows Server 2008 R2.

Thanks

2 answers

1 accepted

This widget could not be displayed.
Hi Linus, when you followed the instructions did you change your context path in step 3.1? If you did does http://localhost/confluence display your Confluence site?

No I skipped that step because I have only one site which is Default Web Site. The server is completely new and and is dedicated only to Confluence. So I expect Confluence to show up at http://localhost/

Does the troubleshooting section of http://tomcat.apache.org/connectors-doc/webserver_howto/iis.html help? If you haven't changed the context that Confluence is served from it's normally a typo in isapi_redirect.properties or in the name of the "jakarta" virtual directory.

Hope that helps?

Andrew.

I look at the link and it made me realize that my tomcat_iis_connector folder needed looser permissions. That done and the isapi_redirect.log now contains something. I enabled debug logging and I can read in the log file that the request is received by the isapi filter and forwarded to port 8009, where the Confluence AJP connector is answering. But it returns a 404 and that is what I see in the browser. Any ideas on how to move on from here?

What have you got in your uriworkermap.properties file? It should be something like:

/*=worker1

Also, can you still access Confluence directly at http://localhost:8090 ?

The uriworkermap.properties has exactly that line. Also I believe that it said in the debug log of the isapi filter that the URI matched and it was passed on to port 8009 - which returned 404. So the URI matching should be OK. I'm not misunderstanding something.

I cannot access confluence at all, the standard connector in the server.xml file on port 8090 I removed (like it said in the documentation). And now it's on 8009 instead but a different typ of connector which I can't use via IE, don't know if I'm suppose to or not.

Sorry, I hadn't picked up that those instructions said to remove the 8090 connector, not sure why the instructions say to remove it as you can have multiple connectors and having one that you can access athttp://localhost:8090 directly is helpful for checking that Confluence is still accessible.

If it's passing the request to 8009, but returning a 404 then it sounds like there's possibly a typo somewhere with the "jakarta" directory, or the directory that jakarta points to that contains the isapi_redirect.dll file.

Do any of these documents help, they differ slightly from the original documentation you referenced:

http://confluence.atlassian.com/display/DOC/Setting+up+Confluence+with+IIS

http://confluence.atlassian.com/display/DOC/Connecting+Confluence+with+IIS+7

http://confluence.atlassian.com/display/JIRA/Configuring+IIS+with+Tomcat

Andrew.

I found the problem! Apparently I hadn't read the confluence stdout log. When I did so it became apparent that my Swedish character in an XML comment in seraph-config.xml caused an error.

So it all seems to work fine now. I very much appreciate you taking the time. It's always helpful with someone pointing in different directions to help solve problems.

Cool, glad you got it working.

This widget could not be displayed.

Sorry, I hadn't picked up that those instructions said to remove the 8090 connector, not sure why the instructions say to remove it as you can have multiple connectors and having one that you can access at http://localhost:8090 directly is helpful for checking that Confluence is still accessible.

If it's passing the request to 8009, but returning a 404 then it sounds like there's possibly a typo somewhere with the "jakarta" directory, or the directory that jakarta points to that contains the isapi_redirect.dll file.

Do any of these documents help, they differ slightly from the original documentation you referenced:

http://confluence.atlassian.com/display/DOC/Setting+up+Confluence+with+IIS

http://confluence.atlassian.com/display/DOC/Connecting+Confluence+with+IIS+7

http://confluence.atlassian.com/display/JIRA/Configuring+IIS+with+Tomcat

Andrew.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

580 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you