Problem Connecting Confluence to JIRA for User Management Edited

I recently upgraded Confluence and JIRA. Most of it went fine (at least as far as I can tell so far), but Confluence lost its own server URL (reset back to localhost:8090) and connection to JIRA for user management.

Fixing the Server URL was trivial, but reconnecting to JIRA is proving problematic. I'm on the "Configure Atlassian Crowd Server" page and I've set the values for Name, Server URL, Application Name, Application Password, and left the default 60 in the Synchronisation Interval field. Those are the only fields with red stars indicating that they are required. But the "Save and Test" button is disabled so I can't save the changes.

Because I can't save, I'm not sure if hitting the "Test" button tests these settings or whatever was there before I updated them, but if it is this new value, then perhaps the error message displayed when I hit Test is relevant: "Connection test failed. Response from the server:
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"

Why and what do I need to do?

Thanks,
Colin

1 answer

This widget could not be displayed.
Ann Worley Atlassian Team Jan 04, 2018

Hi Colin,

I understand you cannot save your Jira User Directory in Confluence because the save and test button is disabled. Until the test button tests the settings and comes back without an error, the User Directory cannot be saved.

The error you are reporting (PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target") is a result of the java trust store in Confluence not trusting the SSL certificate for Jira.

When Confluence was upgraded it may have changed the trust store being used for Java and the certificate from Jira is not in the new trust store.

Please follow this guide to get Confluence to trust Jira's SSL certificate: Unable to Connect to SSL Services due to PKIX Path Building Failed

 After that the test button should work, so you can then save and test.

Please let me know any questions or how I can help.

Thanks,

Ann

 

 

I just fixed it and it was totally my fault. You're right about the cause. Specifically, I had skipped one of the steps in the upgrade process from my own checklist -- update the CACERTS file in both the JIRA and Confluence JRE\Security folders so it recognizes the internal Root CA we use. As soon as I set that, the Test button worked, and that enabled the Save and Test button. 

I do think, from a UI perspective, it's odd that Save and Test is disabled until after hitting the Test button. Both because Save and Test appears "before" (to the left) of "Test" and because it includes the word "Test" it's not at all obvious that it's necessary to hit the "Test" button before the "Save and Test" button becomes active. By the wording and position of the buttons, I had assumed that "Save and Test" was necessary to update the values on the page, and that you could then also run "Test" on the saved values at any time without having to save any changes. I suggest changing the wording and/or positioning of these buttons to make it clearer that it's actually necessary to Test BEFORE it's possible to Save and Test.

Ann Worley Atlassian Team Jan 04, 2018

I am happy to hear you were able to get your User Directory configured.

I opened a suggestion ticket to pass your feedback to the dev team: Reverse positions of "Save" and "Save and Test" buttons for User Directory configuration

Feel free to watch the issue or comment to add weight to the use case. Doing so will add you to notifications so you will see any progress or other response.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

279 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you