Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Power Point pptx - Preview Thumbnails Letters are scrambled / Wrong Rendering Edited

Dear community,

i would like to ask you for your help because i dont know how to solve my problem any further.

We are hosting a confluence via docker with the lates images (currently 7.2.0) . Somehow after the lates update, the preview pictures from office files like docx or pptx. are not beeing rendered correctly anymore.

For example a simple pptx with one slide.

The preview-thumbnail looks like this :

 

example 1.jpg

It kinda looks like a chinese symbol , but i think the letters are just mixed together

When you open the detailed view it looks ok:

 

example 2.jpg

 

To solve this problem, i tried the workarounds from here :

https://confluence.atlassian.com/confkb/the-text-in-a-powerpoint-excel-or-word-document-is-missing-or-looks-different-when-using-the-viewfile-macro-200213562.html?_ga=2.80467423.935751216.1578468581-91470153.1575539057

 and here

https://community.atlassian.com/t5/Confluence-questions/Garbled-text-in-document-preview/qaq-p/873262

So i tried to delete the mentioned folders and installed the mscorefonts. Nothing helped.

There is even no error inside the confluence log regarding fonts or something similar.

Can you help? If you need any more further information, please let me know!

Thank you very much!

 

 

 

 

5 answers

1 accepted

3 votes
Answer accepted
Igor M_ Atlassian Team Apr 28, 2020

Hello,

You could be facing https://jira.atlassian.com/browse/CONFSERVER-59429 bug. 

Depending on your Confluence version, could you change your Java to either jdk8u202-b08 or AdoptOpenJDK 11.0.7 +10 following https://confluence.atlassian.com/doc/change-the-java-vendor-or-version-confluence-uses-962342397.html KB? 

Thank you. That's it. By using AdoptOpenJDK 11.0.7 +10 this issue is gone.

0 votes
Minh Tran Atlassian Team Jan 09, 2020

@René Jansen Can you please tell me what docker image have you used?

HI @Minh Tran ,

thank you for your asking. We are using the latest Image. Its the official one from docker / attlassian libary .

Atlassian Confluence  7.2.0

From the yml-file:

image: atlassian/confluence-server:latest

Minh Tran Atlassian Team Jan 09, 2020

Can you please try with this?

apt update && apt install -y fontconfig

I did this inside the confluence-container :

 

root@afee0f160d19:/var/atlassian/application-data/confluence# apt update && apt install -y fontconfig
Get:1 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1,344 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages [186 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages [13.5 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [11.3 MB]
Get:9 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [6,781 B]
Get:10 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [21.8 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [35.5 kB]
Get:12 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [777 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [10.8 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [1,074 kB]
Get:15 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1,325 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic-backports/main amd64 Packages [2,496 B]
Get:17 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [4,241 B]
Get:18 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [796 kB]
Fetched 17.4 MB in 2s (9,861 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
5 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree
Reading state information... Done
fontconfig is already the newest version (2.12.6-0ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

 

It looks like its allready installed. Do i need to restart confluence?

Minh Tran Atlassian Team Jan 09, 2020

yes please restart Confluence. However, can i have one sample of your pptx? I can try to spin up one instance and see what is really happening

Okay, i restarted confluence and reuploaded a new test pptx. Sadly no change, but here is the test-file :

http://s000.tinyupload.com/index.php?file_id=08892726251295214185

I hope you dont mind that i used that filehoster.

Minh Tran Atlassian Team Jan 09, 2020

No worries. I will give it a try tomorrow. It is night here

Thank you very much, i appreciate that!

Minh Tran Atlassian Team Jan 15, 2020

@René Jansen I set up docker image with your pptx, i truly can reproduce the problem.

However, i think your problem is pretty similar like this ticket https://jira.atlassian.com/browse/CONFSERVER-57588?_ga=2.228450781.1300032409.1578869033-1327961374.1575025993

Can you see its workaround solution and let me know if that works?

Hi @Minh Tran ,

i added

CATALINA_OPTS="-Dconfluence.document.conversion.fontpath=/usr/share/fonts/ -Dconfluence.document.conversion.slides.defaultfontname.regular=IPAGothic -Dconfluence.document.conversion.slides.defaultfontname.asian=IPAGothic -Dconfluence.document.conversion.slides.defaultfontname.symbol=IPAGothic ${CATALINA_OPTS}"
CATALINA_OPTS="-Dconfluence.document.conversion.words.defaultfontname=IPAGothic ${CATALINA_OPTS}"


to the setenv.sh and restarted confluence. Sadly it did not help. The Problem seems not font related. If you just upload a empty pptx with just one letter, this letter is displayed correctly.  It looks like it is not able to "understand" the empty spaces beetween the words and just ignores them during the creating of the thumbnails.

Hi @Minh Tran ,

where you able to reproduce the behavior?

Does some else maybe know the reason for this or has a clue where to check any further?

René

Minh Tran Atlassian Team Jan 13, 2020

@René Jansen Sorry, i was busy the last 2 days with the team project. I am flying tomorrow back to my country for my vacation

When i am there, i can take a look for reproducing your issue in my spare time

sorry this not solved, i just pressed the wrong button :/

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

384 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you