Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Plugin build error: copy-bundled-dependencies failed

I know this question has been asked elsewhere, but the accepted answer didn't work for me.

I've been given a Confluence plugin to debug, and I haven't been able to build it. It gives the following error on build:

 

Execution default-copy-bundled-dependencies of goal com.atlassian.maven.plugins:maven-confluence-plugin:4.1.4:copy-bundled-dependencies failed: An API incompatibility was encountered while executing com.atlassian.maven.plugins:maven-confluence-plugin:4.1.4:copy-bundled-dependencies: java.lang.NoSuchMethodError: org.apache.maven.execution.MavenSession.getRepositorySession()Lorg/sonatype/aether/RepositorySystemSession;

 

I've seen a lot of resources online saying that it's due to a mismatch of AMPS and Maven versions. However, I've used this AMPS version with my current environment to build other projects (my environment is the following):

 

ATLAS Version: 8.0.16
ATLAS Home: D:\PROGRA~1\Atlassian\atlassian-sdk-plugin-8.0.16
ATLAS Scripts: D:\PROGRA~1\Atlassian\atlassian-sdk-plugin-8.0.16\bin
ATLAS Maven Home: D:\PROGRA~1\Atlassian\atlassian-sdk-plugin-8.0.16\apache-maven-3.5.4
AMPS Version: 8.0.2
--------
[INFO] Project POM found
Executing: "D:\PROGRA~1\Atlassian\atlassian-sdk-plugin-8.0.16\apache-maven-3.5.4\bin\mvn.cmd" --version -gs D:\PROGRA~1\Atlassian\atlassian-sdk-plugin-8.0.16\apache-maven-3.5.4/conf/settings.xml
Apache Maven 3.5.4 (1edded0938998edf8bf061f1ceb3cfdeccf443fe; 2018-06-18T04:33:14+10:00)
Maven home: D:\PROGRA~1\Atlassian\atlassian-sdk-plugin-8.0.16\apache-maven-3.5.4\bin\..
Java version: 1.8.0_161, vendor: Oracle Corporation, runtime: D:\Program Files\Java\jdk1.8.0_161\jre

 

(And my pom.xml file contains the following properties:)

 

<properties>        

  <confluence.version>5.5.4</confluence.version>        

  <confluence.data.version>5.5.4</confluence.data.version>        

  <amps.version>5.1.2</amps.version>        

  <create.content.version>2.1.7</create.content.version>        

  <jira.plugin.version>5.1.0-m3</jira.plugin.version>

  <xvfb.enable>false</xvfb.enable>

  <xvfb.display>:0</xvfb.display>        

  <http.port>1990</http.port>        

  <http.confluence.port>${http.port}</http.confluence.port>        

  <context.confluence.path>confluence</context.confluence.path>        

 <baseurl.confluence>http://localhost:${http.confluence.port}/${context.confluence.path}  </baseurl.confluence>    

</properties>

 

I've tried a bunch of different configurations, and haven't been able to get it to build. I don't really understand Maven black magic well enough to know what's really going wrong and why. If anyone could point me in the right direction, it would be greatly appeciated!

1 answer

0 votes
Fabian Lim Community Leader Dec 23, 2021

Hi @sarahc,

For plugin development questions you may be better off posting them at the developer community.

Regards

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

🏠 Say hello to the new Confluence Home!

Hi Atlassian Community, My name is DJ Chung, and I’m a Product Manager on the Confluence Cloud team. Today, I’m excited to share a new and improved version of Home. The new Home helps you ...

43,931 views 33 137
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you