PlugIn for Confluence Serve doesn't work

Hello, 

I have a Server of Version 4.2.2. 

Can it be, that there is no support of Draw.io PlugIn for this version?

I have installed it and activated with trial License. When I click on "Insert a Draw.io Diagram" I see just a blank page.

Thank you

1 answer

0 vote

Are you using a version of the add-on valid for Confluence 4.2.2 ?

How can I check it?

Should I install the PlugIn from this Page https://marketplace.atlassian.com/plugins/com.mxgraph.confluence.plugins.diagramly/versions

for the Confluence Version 4.2.2? This will accord to the version 4.0.0 listed in the first column, which is named Cloud (btw why?smile) . Is this right?

Yes, that's the right list and hence you've looked at the right versions.  You can see the installed version by looking at the list of add-ons under Admin -> manage addons

 

Forget Cloud, if you're running Confluence 4.2.2, it's not Cloud (that's on 6 and handles the add-ons for you)

By Diana Kr:

Thank you for the answer. I have installed the correct version of plugIn. It still doesn't work unfortunately. I have fetched out the source code of Iframe, which should be loaded. It looks like the licence information is not tranferred correctly. I have an evaluation Licence Key. Please have a look:
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=5,IE=9" ><![endif]-->
<!DOCTYPE html>
<html>
<head>
<title>Diagramly</title>
<script type="text/javascript">
var drawioResourceRoot = '/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor';
var returnUrl = 'myWikiServerPage';
var CEO_ID = '22184063';
var contextPath = '';
var baseUrl = 'http://wiki';
var VALID_LICENSE = ${validLicense};
//var EVAL_OR_NO_LICENSE = true;//${IsEvalOrNoLicense};
var PLUGIN_VERSION = '4.0.0';
var LANGUAGE = 'en';
</script>
<script type="text/vbscript">
Function mxUtilsBinaryToArray(Binary)
Dim i
ReDim byteArray(LenB(Binary))
For i = 1 To LenB(Binary)
byteArray(i-1) = AscB(MidB(Binary, i, 1))
Next
mxUtilsBinaryToArray = byteArray
End Function
</script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/rawinflate.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/rawdeflate.min.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxProperties.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxEditorProperties.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/AtlasFile.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/AtlasClient.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/jscolor/jscolor.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/spin/spin.min.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/jquery-1.11.1.min.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxReader.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxBase64.js"></script>
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/index.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/grapheditor.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/plugin/reader.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/atlas.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/plugin/common.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/plugin/mx-editor.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/plugin/aui-buttons.css">
<link rel="stylesheet" type="text/css" href="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/styles/plugin/linkBrowser.css">
</head>
<body class="geEditor">
</body>
<script type="text/javascript" >
if (typeof(JSON) == 'undefined')
{
document.write('<script src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/json/json2.min.js"></scr' + 'ipt>');
}
</script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxDialogs.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxCommonDialogs.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxEditor.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxEditor-Confluence.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxEditorStart.js"></script>
<script type="text/javascript" src="/download/resources/com.mxgraph.confluence.plugins.diagramly:drawio-editor/js/mxImageExport.js"></script>
</html>

12669143_10207488975295707_342300912_o.jpg

I have asked my college to write the answer from his account because of your strict rule of not more than 2 messages per day, if the user has no karma points

Ok, I think you need to be reading the application log at this point - there should be something in there that is logging the actual error.

Hello,

I have no access to application logs. Do you mean the logs on Wiki-Server?

If you take a look at the source code I sent you, you can see the line "var VALID_LICENSE = ${validLicense};"

It looks like the license was not applied. Thus I have entered the license key for a trial version.

On the screenshot you can see the Syntax error "Unexpected token {" on the line with license info.

Could you help me with this information further?

I have also tried to install and activate Gliffy Plugin for Confluence. It has worked from the first time without any problems.

 

If you have applied a valid licence, then it should be working.  Just looking at what eventually ends up in the browser simply isn't good enough for debugging - you do not know if it's the licence at all from that, and even if it is a problem with the licence, the message you get is being caused by something going wrong on the back end.

You must read the application logs on the server to see what is going wrong.  The error is not being caused on the client side, it's something on the server, so that's where you need to look.

 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

915 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you