Pictures not showing in IE after upgrade to Confluence 4.3

I am very new to this so if this is a simple question please be understanding. The Confluence Wiki was upgraded this last weekend, according to my System Admin, to 4.3. Since then I have been hearing problems of pictures not displaying in IE. The pictures do show if the page is opened in Firefox. The pictures were setup in the Mockup plugin.

Can someone point me to an area where I could start looking for a solution?

4 answers

1 accepted

Accepted Answer
0 votes

Hello!

This problem could be related to a reported bug in Confluence, I'm afraid the workaround would be manually uploading the lost profile pictures. You can read more about on the following bug:

https://jira.atlassian.com/browse/CONF-21915

That's also a duplicated of the bug:

https://jira.atlassian.com/browse/CONF-22298

It clarify in a better form to you how it happens, why it happens and a proper workaround.

Kind Regards.

0 votes
David Mason Atlassian Team Oct 28, 2012

Hi Greg,

This happens as a result of a combination of things:

  1. Since Confluence 4.3, the "nosniff" directive is sent in the HTTP headers by Confluence, as a security measure. This tells browsers to strictly obey the MIME type. In the case of IE8 and IE9, if the MIME type is either invalid, or does not match the content being sent, then a broken link will be displayed.
  2. Balsamiq Mockups for Confluence saves images with the "img/png" MIME type, which is invalid. There is a fix for this available in version 2.2.2 of Balsamiq Mockups, which makes it save images with "image/png" MIME type. Any existing saved images will not have their MIME type automatically updated upon installing this update, however.

Regards,

David

David Mason Atlassian Team Feb 26, 2013

Just for an update on this, we have the bug https://jira.atlassian.com/browse/CONF-26848 which describes the symptoms I've discussed above.

Hi,

this short DB statement saved my day

update attachments set contenttype='image/png' where contenttype='img/png';

Regards,

Wilm

Hello,

I've updated mockup v2.2.4 in my Confluence 4.3.7. But mockups not work in IE (new mockup and editing existing mockup from v2.1.5)

In Firfefox mockups work fine.

I ve replaced in my DB the contenttype=image/png and shows the images.

Any suggestions for mockups works in IE?

I ve Windows 7 and IE 8

Thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 09, 2018 in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

381 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you