Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,116
Community Members
 
Community Events
165
Community Groups

Pasting an Excel chart not working

Edited

Has anyone else experienced a new problem with pasting an Excel chart onto a Confluence page?

It has previously worked fine as follows:

  1. Create a chart in Excel.
  2. Copy the chart
  3. Paste onto a Confluence page - Confluence creates a PNG file "on the fly" as the attachment

EASY!   Very User friendly 👌👍😁

But as of a few days ago when we save the page it now shows an "error line" as follows

com.atlassian.confluence.content.render.xhtml.XhtmlException: Missing required attribute: {http://atlassian.com/resource/identifier}value

And that error message hyperlink is to a "404 page not found"

We have replicated the problem in different Spaces using different spreadsheet and dummy data

We have been on v 7.2.1 for a few years now.

the page has successfully pasted images earlier in October .. but now Confluence won't even show the new pasted charts as at attachment .. i.e. it doesn't even appear as an attached file like the older charts do.

Anyone know what has happened?

the temporary and annoying work around seems to be:

  1. Select the chart in Excel, press Copy
  2. Then Paste the chart into Powerpoint or Word etc
  3. Right-click the image in Powerpoint and select <<Save as Picture>> - best choice is probably to save as a PNG file
  4. Then in Confluence insert that PNG file

 

1 answer

0 votes
Fadoua Community Leader Nov 14, 2021

@Rodney Hughes 

Why do you copy/paste?

  • Add the attachment to the list by clicking on the icon in Confluence. But don't insert it in the page
  • You click on Macros -> Excelsheet, you should be able to see your chart directly in Confluence

@Fadoua 

Because we specifically don't want the "source" spreadsheet attached .. just the image of the chart

the source spreadsheet has other data that we don't want accessible by other Users

Also the spreadsheet has several tabs with more than one chart on each tab so its not as simple as using the Excel macro to show the spreadsheet chart

 

... and of course why shouldn't I be able to copy paste from anything and have it attach as an image?  It worked that way previously so something has changed ???

Like Fadoua likes this
Fadoua Community Leader Nov 14, 2021

That makes totally sense @Rodney Hughes .

  • Any change in the instance this week?
  • Is it happening to more than one user?
  • Did you try to open Confluence and try the same steps from another browser?
  • Did you check the logs?

Sorry I know too many questions, however it is the only way to troubleshoot.

Best,

Fadoua

We are a global industry association.

the User who reported it on Friday was in the USA using a PC with Edge.

I replicated the problem here in Australia on Saturday using my PC with Chrome.

This morning (Monday) I again replicated the problem with a fresh spreadsheet on a new page in a different Space.

I have asked our Host to look into it.

Like Fadoua likes this
Fadoua Community Leader Nov 14, 2021

Then in this case only Logs can tell us what's going on.

I have the very same issue; it started about a week ago.  For years, I've been able to paste graphs and charts directly from Excel into confluence.  Now, suddenly, it no longer works.  The workaround I'm using: 

1. Select graph and copy from Excel.

2. Paste into another app (I've been using Paint on Win)

3. Copy from that app

4. Paste into confluence.  

Like Rodney Hughes likes this

I am getting this same result pasting an image from PowerPoint onto Confluence - this worked two weeks ago but I noticed the change yesterday - this appears to be the part where the paste buffer image gets rendered on the confluence page - If i have PowerPoint render the pages into jpgs and then drag the files onto the page they display fine.

A workaround is to put the excel image into an image file than drag it onto the page

Like Rodney Hughes likes this

@Fadoua 

This is obviously more than just my instance.  And I have multiple Users in our system reporting the problem so I am dreading all 6500 Users whinging to me.

Have yo been able to do your own testing?

I am still waiting for the Logs from my Host

Fadoua Community Leader Nov 17, 2021

@Rodney Hughes  My personal instance is Atlassian Cloud. Let me try it in Server instance in 2 different versions then get back to you in the morning.

I wonder what triggered this behaviour since you are a Server user.

 Will have an answer for you no later than tomorrow morning.

Best,

Fadoua

@Fadoua 

Did you have any luck?

Just had a thought .... I just checked the Build revision on my Excel and Office suite... looks like it was updated (automatically) on 12th Nov which is coincidentally (???) similar to when we started seeing the problem.

Although the problem doesn't seem to have also appeared in my second Confluence instance as CLOUD

Perhaps others in this thread can check their Office build?

I found mine is 16.0.14527.20276

That can be seen either through the Windows Settings <<Apps and Features>>

or from Excel side menu <<Account>>

My Excel version:  2109, Build 16.0.14430.20154

Fadoua Community Leader Nov 22, 2021

@Rodney Hughes  My apology we had a major upgrade last week. We finished it over the weekend.

Now Systems are stable and accessible I will test in our DC instance.

Best,

Fadoua

Fadoua Community Leader Nov 22, 2021

@Rodney Hughes I tried copy/paste from an Excesheet to our Confluence DC it worked. It only copied the information I wanted not the whole page 

Fadoua Community Leader Nov 22, 2021

One thing to keep in mind copy/paste in Confluence doesn't save the picture as an attachment. If you ever upgrade all those copied/pasted pictures will show as "Unknown attachment"

@Fadoua 

Thanks for the feedback.

  As soon as I get the logs from our host I'll let you know.

What version Confluence and what Excel version/build were you using.

We are Server 7.2.1 and Excel 2019

You can see where in October my User has copied the first chart images into the page without problem ... Confluence previously did convert them all "on the fly" to actual attachments with time stamps when you pasted.

Capture.PNG

But when he and I try to do that now on the same page, it is not creating the PNG files at all anymore, and it only shows as "Unknown Attachment"

I even created a blank page in a different Space and that now completely fails to create the PNG "on the fly"

Something has changed somewhere (yet we have not done any version upgrade) that it no longer creates the PNG file .. 😞

Fadoua Community Leader Nov 25, 2021

Are you still facing the same problem @Rodney Hughes ?

@Fadoua 

Indeed I am .... I talked our Host through replicating it from his PC ... and it failed for him as well

he is in the process of giving me the log file

I can confirm the problem is that when we paste into Confluence, although it first appears on the page whilst in Edit mode, as soon as you Save, it is not actually creating/attaching the PNG file of the image so it becomes an "Unknown Attachment"

BUT ... seems Atlassian have known about this since 2019!!

https://jira.atlassian.com/browse/CONFSERVER-65792

and affects more than jus Excel images.

Fadoua Community Leader Nov 25, 2021

Yeah logs would be very very helpful

@Fadoua 

I have the log file ... it is 22 MB

How can I get it to you - probably not a good idea to post it here

Fadoua Community Leader Nov 26, 2021

😊definitely not

fboualem@gmail.com

Fadoua Community Leader Nov 26, 2021

Having issues to access the logs. I try to access a space but then it throws an error that the Space is restricted @Rodney Hughes 

Hi all.

Although my original post here was for our industry association's SERVER v7.2.1 instance, I was just doing some work in a page in my own company’s CLOUD instance … same problem .. the chart image was not automatically saved “on the fly” as an attachment file, so it is not just SERVER that has this problem now.

Fadoua Community Leader Dec 05, 2021

@Rodney Hughes 

it is not that I don't believe you but it could be a problem with Excel itself. 

Are you experiencing this issue with any other MS office or PDF documents? Please try to copy/paste the same chart from your Excelsheet into word. Then try from word to do a copy/paste to Confluence page.

I just tried a document from Excel to my Confluence Cloud. It worked.

All the best,

Fadoua

@Fadoua 

1., Atlassian have known of this bug for over TWO YEARS
https://jira.atlassian.com/browse/CONFSERVER-65792 
It seems to be OK if you are using 32 bit Excel, but not if using 64 bit  ... noting I last installed my MS Office in 2019 so why has it suddenly changed?

2. others here using other Confluence instances have said they experience the problem when pasting images from Powerpoint ... I haven't specifically tried.

3. I am now suffering the problem in BOTH of my CLOUD and SERVER instances

4.  my Excel 2019 was auto-updated in mid October - not yet sure about the Excel version of my first User to have reported the problem to me in early November.

5 we have not upgraded our SERVER licence for a couple of years ... although I guess our Host does some tweaks and patches for all manner of miscellaneous issues that don't (normally) directly affect the Users as a "version"

6.  of course Atlassian manages the CLOUD instance upgrades, tweaks and patches

So there is some logic or potential to saying it is Microsoft.

In the "good old days" (pre mid October 2021) I could paste into my Confluence pages no problem ... the image would show in the Edit window perfectly.

Then when I Saved the page, the image was stored as an Attachment with a date and time based PNG file name.

Now Edit mode shows fine, but after I save the page, the new PNG file doesn't exist, hence "unknown attachment/missing properties error!

 

What is clear is that Confluence and Microsoft things are not playing together nicely anymore ... I suppose I should throw GOOGLE Chrome in my case as a possible culprit.

At the end of the day we are experiencing the problem only when we use Confluence

So hopefully ATlassian are taking this seriously - their jira ticket mentioned early says it is "In Progress"

Fadoua Community Leader Dec 05, 2021

Please check the following as I am seeing this error a lot on the Application logs:

https://confluence.atlassian.com/confkb/confluence-page-attachments-fail-to-load-with-a-file-io-error-215483807.html

I have the same problem. I used to be able to copy any picture in confluence.

Now nothing is accepted in confluence anymore, that includes Excel plots, computer screen shots, images from a website, an excel plot that was copied in powerpoint as JPG and then copied to confluence.

the only thing that works is downloading or saving an image as JPG.file and then upload image in confluence.

I am getting desperate. 

Hi Paul

refer this issue:

https://jira.atlassian.com/browse/CONFSERVER-65792

Atlassian have said on 15th Feb

"A fix for this issue is available to Server and Data Center customers in Confluence 7.16.1"

We are in the process of testing the upgrade on our test platform for general compatibility for our Users ... I hope to test the copy/paste within the next week

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.2.1
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

350 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you