Participants custom field not working in JQL

Hi,

I have enabled the Jira toolkit plugin in our OnDemand instance, however, when I try to use the "Participants" filed:

Participants = currentUser()

Even though I am assigned, reported and commented in many issues no results are diplayed on the issue navigator. Any idea why?

Cheers

5 answers

1 accepted

0 vote
Tarun Sapra Community Champion Aug 05, 2014

Just to add what Nic has already shared, I refrain from using names of custom fields in the JQL instead use "cf[1003]" i.e. the id of the custom field

I tried id participants custom field ID in our OnDemand instance, not working :(

However, thks :)

0 vote

Have you done everything you need to enable this?

1. Created a new field of type participants, called participants, with a global context? (I assume you probably have, but need to check!)

2. Re-indexed the entire installation

Hi and tks for the quick reply,

1. Custom field is created with global context (/)

2. How do I re-index the installation? by disabling and enabling toolkit again?

Admin -> Indexing -> Reindex

It worked, many thks!

I have added the addon to my ondemand jira and the participants is not working i get:

Field 'participants' does not exist or you do not have permission to view it.

Can someone please help? I basically enabled the addon and re indexed.

when i search for participants i get the below message :

Your search did not match any custom field types.

Custom field types have been found in other categories

Have you created the custom field?

If not:

  1. go to admin
  2. Issues
  3. Custom fields
  4. add custom field
  5. search for "Participants"
  6. Add field
  7. Then should work

Click on the "All" category and then search there, you are searching on the "Standard" category

I think, as Bernado has suggested, you are missing a step.

You need to:

  • Enable/install the plugin
  • Add a new field, of *type* Participants, and called something like "Participants"
  • Re-index Jira

It sounds like you are assuming that just adding the plugin is enough - it is not, you need to add and index the field as well.

when you search in custom fields menu I supose?

ok perfect. found it. Just added it and now re indexing.

I will let you know how it goes

worked.. thanks a lot.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,486 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you