Parent page with No Child Page

davidsherer August 22, 2022

I have a parent page with no child page
con-ht-menu.png

How can I find the child page or have this page marked as a child?

6 answers

1 accepted

1 vote
Answer accepted
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
August 22, 2022

There's nothing wrong with a page having no descendants.  You have to stop somewhere, otherwise you'd have an infinite recursion.

I suspect what the highlighted line is trying to tell you is that there are child pages of that one, but you can't see any of them.  Check with the space admins what pages are restricted.

(There's also a possible caching/queuing problem - Confluence doesn't index everything immediately.  If a child page there has been deleted or moved elsewhere, and you've caught it before the index gets built for that page, it can show the "parent has child pages" > sign, but then not actually be able to list them.  Give it 10 minutes and refresh the page to see if it's that)

davidsherer August 24, 2022

I am the admin. There are no hidden pages and it has been this way for weeks. Yes there is nothing wrong with it but I have like the Monk (Tony Shalhoub) syndrome. and this really bothers me. 

Like # people like this
Lusia Zaitseva
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 26, 2022

I have this exact same question and problem!

Like Dan Constantinescu likes this
vova_rubinets October 14, 2022

Same issue for me. It happens if you create a child page from it by mistake and then close it without saving. Since the child page wasn't saved - you can not return to it and remove. So, this "parent" flag remains forever.

Very irritating. How to fix?

Like # people like this
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 15, 2022

Delete the draft of the child page.

vova_rubinets October 15, 2022

That draft is not visible, so it's not possible to open or select it to be able to remove.

And creating the new one - opens a new draft, but not the previous one

Like # people like this
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 15, 2022

Ok, so does the draft not show when you go to the "global" confluence menu and hit "drafts" from the list on the left (overview / recent / starred / drafts)?

vova_rubinets October 15, 2022

On this computer - no, global "drafts" page is empty. But I will check on Monday on the computer where I created that draft. Will tell you the results.

Like # people like this
Timur Amirov October 27, 2022

Same problem. New page created by mistake and closed without saving to cancel.

Sometimes it also happens if I drop a page A on another page B and drag A back out of B. The page B remains expandable, without children.

Nothing in "Drafts".

Any solution?

Like # people like this
Paul Sharkey
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 23, 2023

I archived the parent page of the ghost page and then restored the parent page from Archive. This removed the expandable down arrow from the parent page.

Like # people like this
Sam Quinan January 23, 2023

Just tested and archive/restore seems to have worked on my end! While it would be nice if the default behavior were fixed, this seems to a viable workaround. 

Like Claudio Codispoti likes this
Peter Celuch
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 26, 2023

Wow. Putting page into archive worked well. However, restoring is failing with a stupid message that my team has a huge archive queue... 1 page... *&^%$!%^&*(

 

EDIT: I changed parent parameter while restoring and it went well this time. Confluence is a mess.

Like Claudio Codispoti likes this
0 votes
Doug Bland
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 22, 2023

I was able to overcome this issue by dragging a page to be a child page and then move it back.

Sunny
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 31, 2023

This is best and simplest answer! 

Edit: However, on refresh the expand reappears.

0 votes
Tiffany Shum
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 21, 2022

This just happened to me. I was able to solve it by making a copy of the page and nesting it under the original ghost parent page. Then I unnested the copy by dragged it back out of the parent page. The original page then changed back from a ghost parent to a regular page level. Once that happened I was able to delete the copy instead of the original page so I was able to maintain the link. I've only tried this once, hopefully this workaround is reproducible.

Tiffany Shum
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 21, 2022

Update: That only solved the problem temporarily. The ghost parent issue returned once the page was refreshed.

0 votes
Jenna Liebe
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 8, 2022

I had the same problem, which has persisted for several weeks. Today I finally solved it by essentially remaking the page (copying all the content from the problem page over to a new page), and then deleting the original. Not the nicest solution, especially if there's a lot of content on the page, but it worked for me.

Unfortunately the renaming trick didn't work and my drafts section was empty, which is why I ended up just recreating the page.

Sam Quinan November 8, 2022

Technically that's precisely what I was doing when the fluke renaming thing happened for me. But I haven't been able to reproduce that outcome.

I have had 2 separate occurrences of catching what I did quick enough and hitting "forward" to return after mindlessly using "back" to undo the act of creating an unintended child page to return to said page and officially delete it. But that's only a solution if you realize know that hitting "back" on an otherwise blank child page (without content there's no autosave which is probably where it gets assigned to "drafts") is what is causing the problem in the first place.

Like Jenna Liebe likes this
Timur Amirov November 8, 2022

The only solution, I had done so far also in such a way. But it has the following disadvantages.

a) It is cumbersome, especially considering how often this happens (even with some Confluence experience, I keep making the same mistake).

b) Once the page is published, the links to it can be shared. Copying the page and deleting the original will invalidate the links.

0 votes
davidsherer October 31, 2022

Just an update on my opening situation. I have done nothing to my system yet the problem is gone. Wish I knew what happened.

Sam Quinan October 31, 2022

Such is often the case with weird bugs / behaviors. Eventually someone will figure how to actually reproduce it and then it'll get patched properly.

0 votes
Sam Quinan October 31, 2022

So I think I just accidentally figured out a solve?

I cannot recreate the issue to confirm, but in trying a workaround I temporarily renamed the offending page and published, and *poof* the page was back to being represented as a child. Renamed it back what I originally had / republished and the change stuck.

Now we just need someone else with the issue to confirm this was not just a fluke...

Timur Amirov October 31, 2022

Already tried it before and just tried again, from the menu and in the edit mode. Unfortunately nothing changed, the page still thinks to have children :(

Sam Quinan November 1, 2022

Ugh. Then whatever solved if for me was a fluke. That's unfortunate.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events