Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Page wont publish, I suspect as it has SQL code snippets

Chris Brown
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Oct 25, 2023


I am trying to publish a page on confluence which has SQL code snippets which contain EXEC etc in it. So I suspect it thinks I am trying to do a injection attack. Is that likely the issue, does anyone know a way to effectively modify the page so that the publish would be happy. Maybe decorate the code in some way so it is benign. Then I could just put a comment on like remove " " around the statements for developers etc. 

1 answer

1 accepted

0 votes
Answer accepted
Marc Koppelaar
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Oct 25, 2023

Hi @Chris Brown 

I can't reproduce your problem on Confluence Cloud.

I have implemented a code snippet on a random page with content;

SELECT Count(*) AS DistinctCountries FROM (SELECT DISTINCT Country FROM Customers); --Executing stored procedure EXECUTE | EXEC <stored procedure name> WITH <execute_option> -- Execting string EXECUTE | EXEC ('sql string') WITH <execute_option> EXEC SelectAllCustomers;

The publish/update succeeds as normal.

Do you use the snippet in another macro from a 3rd party app or just use 3rd party apps, disable them and see if all works.

Then an app is the reason of the problem, if it stil occurs you wil need to contact Atlassian, as it might be an issue with your instance

Chris Brown
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Oct 25, 2023

Thanks. I deleted the page and slowly added the content back in publishing after each stage. That seems to have worked. I had copied direct from Azure DevOps Wiki, this time I did it via word and that seems to have worked. 

Thanks for testing it. 

Like Marc Koppelaar likes this

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events