Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

An existing page is displayed as not found and below the error page lists similar pages in the same space. However, the link points to the same page. The page excerpt is correct.

The page was moved some days ago and was working after that. I tried to restart Confluence but this didn't improve anything.

The error log (atlassian-confluence.log) is empty.

How can I get access to the page again?

1 answer

0 votes
Fadoua Community Leader Jan 21, 2021

@Christoph Bratschi 

There is definitely something wrong with your instance if the logs are empty.

Did you try to check the space settings and see if you can find the page under reorder pages or orphaned pages?

Best,

Fadoua

On the main space page I can see those pages and in the reorder view they are too.

The orphaned pages tab is not available on my instance.

I could reproduce the same issue on my second Confluence instance. There the affected page was never moved.

So far at least 7 pages are affected in three spaces. Some of them contain important content I have to access urgently. Is there anything I can do?

Just after editing and saving a page the not found message was shown. Again it shows a similar page which is the exactly same URL as the one shown as missing and the text summary contains the text added a moment ago.

I tried now to delete the index according to:

https://confluence.atlassian.com/confkb/how-to-rebuild-the-content-indexes-from-scratch-on-confluence-server-110035351.html

But this did not make any difference.

I have important content on these pages. A full space export to XML contained all data and an import in XWiki was showing all pages and their content and revisions.

Fadoua Community Leader Mar 16, 2021

Ok let me see what could be the problem, I will get back to you no later than tomorrow I promise 

Fadoua Community Leader Mar 17, 2021

@Christoph Bratschi  If the logs are empty that is a problem right there. Any application working properly should have the logs 

Also in Confluence go to your Avatar -> Drafts see if you can see your pages there

Are you the admin? If yes what was the most recent change made in the instance it could be the one behind this problem.

Best,

Fadoua

@Fadoua no, this is not related to drafts. These pages exist for a long time and no drafts were saved.

Yes, I am the admin. I regularly updated to the latest Confluence version. Other than that there were no other changes.

Fadoua Community Leader Mar 23, 2021

@Christoph Bratschi  my apology  I was away for few days.

  • When was the last time your Confluence pages were displaying properly?
  • What change did you make that could have triggered this behaviour?

I run two Confluence server instances which are regurlarly updated since 2012. The first time this issue happened was at the beginning of this year. On January 17th I upgraded from Confluence 7.5 to 7.10.1. So it could be possible this is related to this upgrade.

Since February 7th Confluence 7.11 is running and did not improve anything.

I monitored the log file and opened all failing pages but the log file was not updated in those cases.

1) private instance

One page was failing but later on worked again. This page was last updated in 2013.

2) company instance

Pages of two spaces are affected.

4 pages are affected in the first space. One got broken after a save operation. All four pages are fine in the HTML export.

3 pages are affected in the second space. One page failed once but works now again. However, this page is completely missing in the HTML export. The other two failing pages are correct in the HTML export of the space.

This means either content is missing in the HTML export or pages are not accessible anymore.

I tried to rebuild indices but this did not change anything.

I hope one of the developers can shed some light on this issue.

I performed some more tests and collected all pageIds from either Confluence or the HTML export.

Now if I open the pages through either:

  •  /pages/viewinfo.action?pageId=28837337
  • /pages/viewpage.action?pageId=28837337

All displayed data is correct and the full content is visible again. Therefore I think there is an issue with the /display/space/title URLs which are failing in these few cases.

I hope this helps you to further analyze my issue and provide a solution.

Two weeks ago I upgraded PostgreSQL on this Confluence instance from 9.6 to 11. After that the broken pages where running again but today I checked all those links again and they are broken as before.

Sometimes saving the page again fixes it but problems arise later again.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Confluence Cloud

🎨 Add some visual life to your templates

Hi Atlassian Community, My name is Avni Barman, and I am a Product Manager on the Confluence Cloud team. Based on feedback from you, we are giving admins more power to create templates that a...

239 views 4 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you