Page not displaying anything but html macro

I have added a html block to generate some buttons to navigate with.

When I save the page only the buttons are displayed. There are other macros on the page but they do not show:

image2016-6-30 16:37:35.png

image2016-6-30 16:38:12.png

Is the macro overriding the other content on the page?

2 answers

1 accepted

1 vote
Steven Behnke Community Champion Jun 30, 2016

Do not use HTML, HEAD, or BODY tags in the HTML macro. I think that's it.

Excellent thanks! Fixed the problem right away

Steven Behnke Community Champion Jul 01, 2016

Cool, glad that was it. 

The html macro is probably a simple macro like so:

<html>
  $body
</html>

Where $body is the value you're placing inside the macro. 

 

The additional <body> tags conflict with Confluence's tag. 

Yes Joe, As Steve suggested please remove html and body tags and try

html-2.PNG

 

 

 

html-1.PNG

 

Regards

Chander

 

Worked! Thanks for the help!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

380 views 21 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you