It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Office attachments/ files do not open

Hello everyone!

Since uploading from Confluence Server 6.8.0 to 6.13.0 we are not able to open certain office files. We installed the Atlassian Companion App and can click "Edit". Then the Screen stands still with the message: "Opens file in Excel (Desktop)" but does not open the file. We updated our test instance to 6.14.0 and tried again - no difference. This is not the case with every attached files. I tried to find out some similarities, but it happens with xlsx, pptx, docx. Also the size doesn't seem to be an issue, because it's not working with sizes like 32kB, what is not very much. Upload-limit is 50 MB. With the Office Connector I could configure certain things, is this also possible with the Atlassian Companion App? This is a very serious issue for us! Please help!

 

Greedings

Nadja

3 answers

1 accepted

2 votes
Answer accepted

It appeared because of brackets in the file name.

Hi,

I have same issues with attachments filenames containing special characters plus "+" or double dots ":"

Double dots are not allowed with filenames in Windows but "+" should be allowed ?

So yes for the moment, we are removing "+" and ":" and "( )"
Is there others special characters ?

I faced the same problem and removing the symbol "," from the file name fixed the problem.

0 votes
bitvoodoo_nick Community Leader Feb 06, 2019

Hi Nadja

Is your Confluence hosted behind a proxy, WAF or similar? If so make sure websockets come through.

And are are you working on normal Mac or Windows PCs or is it possibly a virtual desktop environment (i.E. Citrix or VMware)? Latter won't work.

See Administering the Atlassian Companion App.

Cheers
Niklas

Hi Niklas,

Confluence is hosted behind a proxy, but I don't see why then certain office files work perfectly fine and others doesn't. I'm working on a normal Windows PC, no citrix or anything.

Anyways, thank you very much for paying attention. Atlassian Support has contacted me in the meantime. I'll keep you posted!

Greetings,

Nadja

Have you managed to solve the issue? I have exactly the same problem.

Hi!

Sorry for not keeping you posted! Atlassian Support could fix the problem. It appeared because of brackets in the file name.

Best regards and thank you both for your interest!

Nadja

Thanks for answering Nadja! Did they state that this is the final solution? Removing brackets from filename seems like workaround for me. Are they working on a fix?

Thanks again :)

Hey, I am indeed facing same issues, & even files with no brackets are not opening for me.

Nadja can you please help here.

Hi everyone,

I just read the mails I wrote with atlassian support. They wrote:

  • It appears the issue is caused by the file name and in particular the "()" characters.
  • I've tested this and the issue is not reproducible on MacOS, so it looks to be a Windows only issue.
  • I have found an almost similar bug report here: CONFSERVER-57769 however we do not receive the same error message.

To solve the problem without changing our filenames, support gave us an kb-article about re-encoding by proxy. Unfortunately I cannot open the link to the article anymore. Perhaps you could contact the support and open a new issue. They helped very quickly and solved the problem in the end.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

327 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you