Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Office Excel macro not working with "We can't preview this file" message

Office excel macro is not working on a confluence page with the message

We can't preview this file. You'll have to download the file to view it.


Just followed the instruction below:

1. Attach file and update

2. Select the office macro on the thumbnail of the attachment


Have any suggestion?


1 answer

0 votes
Fabio Racobaldo _Herzum_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Apr 04, 2023

Hi @hwiheon ,

do you have this behaviour for all xlsx files? If yes, please take a look to the following troubleshooting article,should%20work%20fine%20this%20time.

Hope this helps,


Thank you so much. Fabio. 

I found some previews are normally displayed in another page. 

First I thought was some features of the attachment could generate problem, so I downloaded a normal one and tried to set the macro, but it doesn't work, neither.

It is probably not an attachment problem, but it could any security policy in office or something. 

Could you please give any solution?

Hi @Fabio Racobaldo _Herzum_ 

I found Confluence File was disable in Add-on apps. 

Every module is enabled in the app and waiting for resetting it in a few days. 

Going to leave further result after I tried.


Raminta Raguckaite
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 04, 2023

Did you manage to get solution for this? As we currently experiencing the same issue and I don't seem to manage to find workaround or fixes available. I work in a corporation and don't manage Confluence as administrator so can't really try Fabio suggested action to enabling add ons.



Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events