Not able to start Synchrony service Edited

Not able to start synchrony service on confluence datacenter nodes. I have configured all the variables in start-confluence.sh script. 

It is returning below error when I try: ./start-synchrony.sh -fg

Error: Could not find or load main class synchrony.core

and 

when I try ./start-synchrony.sh, it returns the URL and PID. but when checked with ps -ef | grep <PID>. That PID does'nt exists. There are no logs available for this to verify. I'm using Confluence Datacenter 6.5 

Appreciate if someone has a solution for this issue. 

 

Regards,

Bala

5 answers

This widget could not be displayed.

Just posting the answer here for anyone else, as I had this issue for a solid month and it was just resolved. I also used the Quick Start on AWS.

After a lot of back and forth with Atlassian Support, it appears my issue with a combination of server IP variable and the joining via. AWS tags.

To resolve the issue, I first changed the server IP to be that of my instance's local IP. I then implemented a new AWS tag (synchrony=true), and used that for the cluster joining parameters. One thing I also did (but I am not sure if it would help), was I installed Oracle's JRE vs. OpenJDK.

 

I hope this helps anyone who may stumble across.

Ann Worley Atlassian Team May 18, 2018

Thank you so much for letting the Community know what worked for you, Brenton. 

If OpenJDK was not an issue during your support case it would probably turn into an issue later down the road as OpenJDK is not a supported platform for Confluence:

Confluence will not work with OpenJDK. If you're installing Java yourself, you must use Oracle Java. 

This widget could not be displayed.

Sorry, I don't have an answer, but I did want to say I'm experiencing the exact same issue with Confluence Data Center installed via the Atlassian Quick Start for AWS.

This widget could not be displayed.

Any ideas? Same as both of you utilizing the AWS Quick Start templates.

Hi All,

When configuring synchrony, you need to indicate 2 variables: DATABASE_DRIVER_PATH and SYNCHRONY_JAR_PATH.  

They must indicate to the location of the corresponding JAR files.

 

For example:

DATABASE_DRIVER_PATH="/opt/atlassian/synchrony/postgresql-42.1.1.jar"

SYNCHRONY_JAR_PATH="/opt/atlassian/synchrony/synchrony-standalone.jar"

I have these variables set, and I still receive the same error.

Do you have any other suggestions?

It might be the problem with the synchrony startup script.Go through each parameters path in the script such as java path,ports,db urls and see .One problem with synchrony is that you may not even get the related error.

This widget could not be displayed.

Hi All, 

Setting up the Synchrony on node1 of Data Center and when execute the start-synchrony.sh, receive the below error message

 

Error: Could not find or load main class 

bash: line 1: -Dsynchrony.context.path=/synchrony: No such file or directory

[2018-06-05 09:07:54] Started Synchrony service with PID:

 

The required variables are configured properly, but still receive the error.

DATABASE_DRIVER_PATH="/opt/atlassian/apps/synchrony/mysql-connector-java-5.1.33.jar"

SYNCHRONY_CLASSPATH="/opt/atlassian/apps/synchrony/synchrony-standalone.jar"

SYNCHRONY_CONTEXT_PATH="/synchrony"

Any inputs will be helpful. 

 

Thanks,

Kiran

 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Jul 30, 2018 in Confluence

How Manon Soubies-Camy uses Confluence + Trello to organize webinar notes and her knitting stash

@Manon Soubies-Camy is an engineer who has been an avid Atlassian user since 2014. She helps companies of all sizes transform the way they work with the Atlassian stack, including Jira and Confl...

861 views 8 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you