Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Node02 unable to join cluster after upgrade from 7.13.0 to 7.13.7


We had a working Confluence TST cluster with 2 nodes on version 7.13.0.

After updating both nodes to version 7.13.7 we have the following behavior:

  • node 1 starts just fine
  • once node 1 is completely started we start node 2
  • In the logs we see error messages about the authentication to the cluster and asking to verify the cluster name and secret (both are ok and the same on both nodes)
  • Node 2 than takes the cluster and node 1 get's an error 'Could not open Hibernate Session for transaction; nested exception is com.hazelcast.core.HazelcastInstanceNotActiveException: Hazelcast instance is not active!'

When we then restart node 1, we have the same behavior (node 1 is ok but node 2 crashes with the same error).

So there seems to be a problem with the cluster after the update.

On both machines port 5801 is open on the firewall.


confluencetst02 | 2022-06-15 08:43:04,086 INFO [Catalina-utility-1] [atlassian.confluence.cluster.DefaultClusterConfigurationHelper] lambda$populateExistingClusterSetupConfig$5 Populating setup configuration if running with Cluster mode...

confluencetst02 | 2022-06-15 08:43:04,842 INFO [Catalina-utility-1] [confluence.cluster.hazelcast.HazelcastClusterManager] configure Configuring Hazelcast with instanceName [confluence], join configuration TCP/IP member addresses:|, network interfaces [] and local port 5801

confluencetst02 | 2022-06-15 08:43:04,842 INFO [Catalina-utility-1] [confluence.cluster.hazelcast.HazelcastClusterManager] startCluster Starting the cluster.

confluencetst02 | 2022-06-15 08:43:08,219 INFO [hz.confluence.event-2] [confluence.cluster.hazelcast.LoggingClusterMembershipListener] memberAdded []:5801 joined the cluster

confluencetst02 | 2022-06-15 08:43:08,221 INFO [hz.confluence.event-2] [confluence.cluster.hazelcast.LoggingClusterMembershipListener] logClusterMembers Cluster now has 1 members: [[]:5801]

confluencetst02 | 2022-06-15 08:43:09,483 WARN [hz.confluence.cached.thread-2] [hazelcast.interceptor.authenticator.DefaultClusterJoinManager] checkNodeAuthenticationEnabled CONNECT( -> Node authentication failed: Cluster authentication failed. Please make sure all members share the same value for '' and 'confluence.cluster.authentication.secret' in confluence.cfg.xml.

confluencetst02 | 2022-06-15 08:43:10,330 INFO [Catalina-utility-1] [confluence.cluster.hazelcast.HazelcastClusterManager] startCluster Confluence cluster node identifier is [91d9cc86]

confluencetst02 | 2022-06-15 08:43:10,330 INFO [Catalina-utility-1] [confluence.cluster.hazelcast.HazelcastClusterManager] startCluster Confluence cluster node name is [confluencetst02]


Any ideas?

1 answer

The WARN that you are seeing is in reference to your confluence.cfg.xml in your home directory. It looks like the following two properties:

<property name="confluence.cluster.authentication.enabled">true</property>
<property name="confluence.cluster.authentication.secret">some_secret</property> 


Verify that the secret is the same on both your servers. After making them the same for our servers, all nodes were able to join the cluster

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events