Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

No users in Server after Cloud to Server migration Edited

I'm migrating from Cloud to Server. I have followed the Confluence setup wizard and imported the Cloud backup (zip file) upon Server start, i.e. importing at initialize time and not into an existing site.

When presented with the log in screen, what Username and Password should be used?

I have tried my Atlassian Cloud credentials (email and password), but receive the error:

Sorry, your username and/or password are incorrect. Please try again.

I have tried the "forgot my password" option, but receive the error:

Sorry, you can't retrieve your password as no email service has been configured. Please contact your administrators for assistance.

 

2 answers

1 accepted

Okay, so this has taken me a week to find a solution that can be implemented in docker, hence adding it here for others.

The Step 5: Recover sys admin permissions page does cover what is needed, but not how to do it with docker.

Rather than build my own edited image, this is the solution I came up with:

  • Copied the setenv.sh file out of the standard container to the host
  • Edited my copy of the file to add the required entry
  • Mounted the edited file as a volume in place of the file in the container, e.g. 
    ${PWD}/setenv.recovery.sh:/opt/atlassian/confluence/bin/setenv.sh
  • Started the container and logged in as recovery_admin
  • Completed the User Management steps
  • Finally, restarted the container without the edited file

There is likely a better solution out there, but this worked for me.
Maybe even Atlassian support could respond and offer a better solution?

Okay, I think I have found it, Step 5: Recover sys admin permissions 

Now to work out how to do this in a docker container

I still can't get this to work with the official docker container.

It looks like I should be able to add the system property to START_CONFLUENCE_JAVA_OPTS and it would be picked up and added in setenv.sh, but I'm not having any luck.

It is starting to feel like I'll have is to create my own Dockerfile and image. Has anyone found a solution using the official image?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.4.8
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. (Read m...

530 views 3 23
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you