New installation on Windows fails

So, Atlassian has stopped offering support for paying customers...

Product: Confluence. Self-hosted.

I'm trying to set up a new Windows 10 installation of Confluence, and after battling with the MySQL DB requirements I've hit the wall again.

The installation is a local on, on Windows 10 64-bit. I'm trying to connect to a remote MySQL server.

After solving the MySQL griefs, confluence just failed with a generic, uninformative error page after setting up the database, at the moment I clicked the "Restore from backup" button.

Here's the page:

logo System Error

A system error has occurred — our apologies!

For immediate troubleshooting, consult our knowledge base for a solution.

If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support systemwith the following information:

  1. a description of your problem and what you were doing at the time it occurred
  2. a copy of the error and system information found below
  3. a copy of the application logs (if possible).

Your Confluence administrator can use the support request form to create a support ticket which will include this information.

We will respond as promptly as possible.
Thank you!

Return to site homepage…

The SystemInformationService could not be retrieved from the container. Therefore very limited information is available in this error report. 
The SystemInformationService could not be retrieved due to the following error: java.lang.IllegalStateException: Spring Application context has not been set


    at com.atlassian.confluence.setup.actions.SetupPathsAction.execute(

Stack Trace:[hide]

	at com.atlassian.confluence.setup.actions.SetupPathsAction.execute(
	at com.opensymphony.xwork.DefaultActionInvocation.invoke(
	at com.opensymphony.xwork.interceptor.AroundInterceptor.intercept(
	at com.opensymphony.xwork.DefaultActionInvocation.invoke(
	at com.atlassian.confluence.core.ConfluenceLicenseInterceptor.intercept(
	at com.opensymphony.xwork.DefaultActionInvocation.invoke(
	at com.opensymphony.xwork.interceptor.AroundInterceptor.intercept(
	at com.opensymphony.xwork.DefaultActionInvocation.invoke(

Referer URL



Needless to say, I gave up on this and uninstalled, removed and reinstalled.

This time, the same error occurs again, but now it occurs when I try to test the database connection.

1 answer

0 vote
Ann Worley Atlassian Team Jan 09, 2018

Hi Frank,

The error you are seeing, "Spring Application context has not been set" can be caused by a variety of issues, documented here: Confluence does not start due to Spring Application context has not been set

The most common reason for the error is a lack of permissions on the home directory for the user running Confluence. However, there are database related causes as well. Since you are now seeing the error after the database setup step, cause number 5 on the doc may be a good suspect:

The server does not have enough memory during installation to set up the database, and restarts return this error.

I look forward to hearing what you find out.



Well, since I uninstalled and deleted Confluence, cleaned the database and tried a reinstall, that doesn't seem to be the case. The error now occurs when I try to test the database connection on the new installation, BEFORE the database is set up.

Ann Worley Atlassian Team Jan 09, 2018

There are 10 possible causes for the error message in the article - were you able to rule out all of them? Confluence does not start due to Spring Application context has not been set

That's right. None of the 10 causes were applicable.

I tried reinstalling again. And again. And again. And after four reinstalls, it seems to work. Not sure yet, becuase the estimated time to restore a small site with two spaces is three days.

Ann Worley Atlassian Team Jan 09, 2018

That's an awfully slow restore - what is your Java heap set at for Confluence? This article has the instructions for setting (hence viewing) the memory allocated to Confluence: How to fix out of memory errors by increasing available memory. There are instructions for starting as a service or starting from the batch file, and the instructions are collapsed inside expand macros but the instructions and screenshots are too complicated for me to paste here, so I have to link to it. 

Well, the estimate seems to be highly dynamic. This was ten hours ago. Now the estimated time remaining is 12 minutes.  But it's been that for quite a while, so I expect it to jump up again. But apparently not two days.

EDIT: It's been standing still at 12 minutes and 35 seconds for a long while now. And the text "Entities loaded..." hasn't changed either. My guess, considering the quality of the Confluence installer in my experience, it's not going to finish.

What'll happen if I try to reload the installation page now?

Well. I reloaded the page, and naturally it didn't work. I got this error page:
Confluence had problems starting up

This page is for Confluence administrators. If you're seeing this page, your Confluence administrator is probably working to restore the service.

Post-Upgrade recovery file generation failed.
Please refer to (URL REMOVED)

2018-01-09 23:36:29


No operations allowed after connection closed.

And OF COURSE the link to the "possible solution" didn't have any relevant info or help at all.

Restarting Confluence and trying to access it results in "localhost refused to connect." - Even though the firewall is disabled, and no changes has been made since I tried restarting the installation (WHICH MEANS THAT LOCALHOST WAS INDEED ACCEPTING THE CONNECTION).

Pardon my french, but this is getting downright pathetic. I'M NOT EVEN ABLE TO INSTALL THE SYSTEM ON AN WINDOWS MACHINE!

I'll have to start looking at alternatives to Confluence now, because I don't trust this product to be usable at all. I have one working installation on Linux. But this fails often, and the instance it's not possible to fix I need to know that I can get a new site up with backup/restore. As it is now, this doesn't look promising at all.

And to add insult to injury, this forum complains constantly about not accepting my plain-text post because it contains "invalid HTML).

And even better: The uninstallation script doesn't work, because Trend Antivirus detects uninstall.exe as a threat. Possibly not a big thing, but very, very unnecessary.

The 5th installation attempt lead me a bit further, but things are still not working.

About two hours into the process of restoring the site from the backup, I got this error:

Import failed. Check your server logs for more information. Import mutex held by com.atlassian.confluence.importexport.xmlimport.FileBackupImporter@ffc2c44

None of the logs have ANY information at all. (That is - they were last updated long before the import started and failed.)

No, when I try again, it fails immediately with the same error.

So, I try to skip the Restore and instead just import the MySQL backup into a new MySQL db and point Confluence to that after installation.

Of course this didn't work either.

I was able to finish the Confluence installation with an empty site. Then I shut down Confluence and edited the jdbc string in confluence.cfg.xml.

The result:


10-Jan-2018 16:00:07.357 INFO [Abandoned connection cleanup thread] org.apache.catalina.loader.WebappClassLoaderBase.checkStateForResourceLoading Illegal access: this web application instance has been stopped already. Could not load []. The following stack trace is thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access.
 java.lang.IllegalStateException: Illegal access: this web application instance has been stopped already. Could not load []. The following stack trace is thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access.
    at org.apache.catalina.loader.WebappClassLoaderBase.checkStateForResourceLoading(
    at org.apache.catalina.loader.WebappClassLoaderBase.getResource(
    at com.mysql.jdbc.AbandonedConnectionCleanupThread.checkContextClassLoaders(
    at java.util.concurrent.ThreadPoolExecutor.runWorker(
    at java.util.concurrent.ThreadPoolExecutor$

So I try to change the jdbc string back to the original.

No change at all.

Ann Worley Atlassian Team Jan 10, 2018

So that we can collect more information from you, I created a support ticket on your behalf. You should see an email from the support portal shortly.

Once we have a resolution we can post back to this thread.

Since absolutely nothing works, I'm not sure there's any point in continuing this charade.

Now, after the installation is ruined because I tried to connect it to a backed up database, it's not even possible to restart it. Even after deleting confluence.cfg.xml, the server refuses to start.

10-Jan-2018 16:10:18.980 SEVERE [main] org.apache.coyote.AbstractProtocol.init Failed to initialize end point associated with ProtocolHandler ["http-nio-8090"] Address already in use: bind

What should I do? Use days and days trying to get the site backup to work, or waste days and days trying to solve this latest - completely absurd - problem?

"Address already in use" means something is running there already.  Given what you've been going through, it's quite likely that you've not managed to stop the currently installed Confluence (even though it's not doing anything useful, it's still running).  Have a look for the process and kill it in full if it is there.

Yup, you're right of course. But that's just a "detour" problem.

I've now reinstalled it for the 6th or 7th time. Thinking about trying to do a site restore from the backup AFTER the installation this time.

Suggest an answer

Log in or Join to answer
Community showcase
Kesha Thillainayagam
Posted Mar 05, 2018 in Confluence

We want to know what templates you're using in Confluence!

Hi Community!  My name is Kesha (kay-sha not Ke$ha) and I'm on the Confluence Product Marketing team. We are trying to understand and improve template use cases in Confluence, and are intereste...

2,762 views 38 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot